Bug 426734 - An exception Occurs while just starting Add Remove Software (pirut).
An exception Occurs while just starting Add Remove Software (pirut).
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-25 10:59 EST by Debabrata Deb
Modified: 2007-12-26 13:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-26 13:54:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Debabrata Deb 2007-12-25 10:59:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 479, in main
    pm.run()
  File "/usr/sbin/pirut", line 407, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 423, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0xa2b2f4c>
commands: None
opts: None


Version-Release number of selected component (if applicable):
pirut-1.3.28-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. Just start Add/Remove Software from Applications menu
2.
3.

Actual Results:
It shows a Error Message: Exception Occurred. with a bug report ( that I placed in Description section above). I can only then three options to do : 'Debug', 'Save to File' and 'Quit'. If I choose 'Debug' then nothing happens and just the program (pirut) exits. if I choose 'Save to File' I can then Save the 'crash dump' info and lastly choosing 'Quit' obviously quits the program Add/Remove Software (pirut). Also Importantly now my Automatic software update (pup) does not work. It also shows the same error 'unhandled exception has occurred' with the same (!!!) 'crash dump' info. But there is no problem with YUM UPDATE. yum works fine!!!

Expected Results:
Add/Remove Software (pirut) should start and let me Add/Remove some software from by fedora 8 installation.

Additional info:
Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 479, in main
    pm.run()
  File "/usr/sbin/pirut", line 407, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 423, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0xa2b2f4c>
commands: None
opts: None
Comment 1 Debabrata Deb 2007-12-26 10:02:30 EST
I am not sure about the status of the bug. But I have go an work around. This is
from Fedora forum Thread : 
http://www.fedoraforum.org/forum/showthread.php?t=176323&highlight=pirut+crash

The work around is : 
root has to edit the file /usr/lib/yum-plugins/priorities.py by changing the
line #88 (if opts.samearch:) to ' if opts and opts.samearch: '
 and then do 'chcon -t lib_t /usr/lib/yum-plugins/priorities.py' if SELinux is
activated.

NB : in installation of fedora 8 'rpm -q  pirut' shows i have pirut-1.3.28-1.fc8
installed.




(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10)
Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10
> 
> Description of problem:
> Component: pirut
> Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType'
object has no attribute 'samearch'
> 
> Traceback (most recent call last):
>   File "/usr/sbin/pirut", line 483, in <module>
>     main()
>   File "/usr/sbin/pirut", line 479, in main
>     pm.run()
>   File "/usr/sbin/pirut", line 407, in run
>     self.doRefresh()
>   File "/usr/sbin/pirut", line 423, in doRefresh
>     self.doRefreshRepos(self._onlyrepo)
>   File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
doRefreshRepos
>     self.reposSetup(pbar, thisrepo)
>   File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in
reposSetup
>     self.doTsSetup()
>   File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
>     return self._getTs()
>   File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
>     self._getTsInfo()
>   File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
>     self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
>     pkgSack = property(fget=lambda self: self._getSacks(),
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
>     self.plugins.run('exclude')
>   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
>     func(conduitcls(self, self.base, conf, **kwargs))
>   File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
>     if opts.samearch:
> AttributeError: 'NoneType' object has no attribute 'samearch'
> 
> Local variables in innermost frame:
> conduit: <yum.plugins.MainPluginConduit instance at 0xa2b2f4c>
> commands: None
> opts: None
> 
> 
> Version-Release number of selected component (if applicable):
> pirut-1.3.28-1.fc8
> 
> How reproducible:
> Always
> 
> 
> Steps to Reproduce:
> 1. Just start Add/Remove Software from Applications menu
> 2.
> 3.
> 
> Actual Results:
> It shows a Error Message: Exception Occurred. with a bug report ( that I
placed in Description section above). I can only then three options to do :
'Debug', 'Save to File' and 'Quit'. If I choose 'Debug' then nothing happens and
just the program (pirut) exits. if I choose 'Save to File' I can then Save the
'crash dump' info and lastly choosing 'Quit' obviously quits the program
Add/Remove Software (pirut). Also Importantly now my Automatic software update
(pup) does not work. It also shows the same error 'unhandled exception has
occurred' with the same (!!!) 'crash dump' info. But there is no problem with
YUM UPDATE. yum works fine!!!
> 
> Expected Results:
> Add/Remove Software (pirut) should start and let me Add/Remove some software
from by fedora 8 installation.
> 
> Additional info:
> Component: pirut
> Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType'
object has no attribute 'samearch'
> 
> Traceback (most recent call last):
>   File "/usr/sbin/pirut", line 483, in <module>
>     main()
>   File "/usr/sbin/pirut", line 479, in main
>     pm.run()
>   File "/usr/sbin/pirut", line 407, in run
>     self.doRefresh()
>   File "/usr/sbin/pirut", line 423, in doRefresh
>     self.doRefreshRepos(self._onlyrepo)
>   File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in
doRefreshRepos
>     self.reposSetup(pbar, thisrepo)
>   File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in
reposSetup
>     self.doTsSetup()
>   File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
>     return self._getTs()
>   File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
>     self._getTsInfo()
>   File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
>     self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
>     pkgSack = property(fget=lambda self: self._getSacks(),
>   File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
>     self.plugins.run('exclude')
>   File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
>     func(conduitcls(self, self.base, conf, **kwargs))
>   File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
>     if opts.samearch:
> AttributeError: 'NoneType' object has no attribute 'samearch'
> 
> Local variables in innermost frame:
> conduit: <yum.plugins.MainPluginConduit instance at 0xa2b2f4c>
> commands: None
> opts: None

Comment 2 Jeremy Katz 2007-12-26 13:54:02 EST

*** This bug has been marked as a duplicate of 421961 ***

Note You need to log in before you can comment on or make changes to this bug.