Bug 426757 - Firefox at F8 (not at F7) fails to load internet banking application
Firefox at F8 (not at F7) fails to load internet banking application
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-25 17:19 EST by Marcelo
Modified: 2007-12-29 12:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-29 11:56:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The application in F7, completely loaded (189.62 KB, image/png)
2007-12-25 17:23 EST, Marcelo
no flags Details
The application in F8. The "Cotações" "sub-window" does not finish loading. (158.42 KB, image/png)
2007-12-25 17:25 EST, Marcelo
no flags Details

  None (edit)
Description Marcelo 2007-12-25 17:19:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv: Gecko/20071128 Fedora/ Firefox/

Description of problem:
Inside my bank's internet banking website, there's a page with an embedded flash application that won't finish loading in F8, but will load and function correctly in F7, using the same versions of Firefox and Flash plugin. The application's windows has four independent areas (like frames), one of which doesn't finish loading when using firefox+flash in F8, but will work right in F7. The other window areas, one of them almost identical to the problematic one, loads and work ok.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Unfortunately, I can't guide you in reproducing the problem, because the application is available only after I log in at the bank's internet banking site. However, I can send screenshots of what is happening, capture network traffic, or provide any other information you think it's useful to trace the problem.

Actual Results:
The application won't load completely. The frame which does not finish loading is unusable, the others are usable.

Expected Results:
The application should load completely.

Additional info:
The application require java and flash plugins installed to load. However, I can't see any difference when I load it with and without java installed. I've tried several versions of Firefox, flash-plugin and java (I have even installed Sun's JVM in F8 to test with exactly the same versions I had installed in F7), always with the same results: the application loads and functions correctly in F7, but not in F8 (I've tested with several F7 and F8 machines). Too bad I can't give you access to the site to see exactly what's happening, because it's necessary to be logged in at the bank's internet banking site :(
However, feel free to ask for any information or testing procedure that may help to trace down the problem. 
Please, see the attached screenshots. The area named "Cotações" does not load in F8, it keeps showing the little watch animation and the message "Aguarde..." (which means "Wait..."). In F7, it load and work ok, with the same versions of firefox, flash and java. See that the bottom-left tabbed "sub-window" is very similar to the "Cotações" "sub-window", but it works in F7 and in F8.
Comment 1 Marcelo 2007-12-25 17:23:06 EST
Created attachment 290386 [details]
The application in F7, completely loaded

This picture shows the application completely loaded and functional when loaded
in firefox at an F7 box. See that the "sub-windows" named "Cotações" is
loaded and that the edit boxes named "Lista" and "Ativo", at it's bottom, are
Comment 2 Marcelo 2007-12-25 17:25:27 EST
Created attachment 290387 [details]
The application in F8. The "Cotações" "sub-window" does not finish loading.

This screenshot shows the application when loaded in firefox at an F8 box. See
that the "sub-window" named "Cotações" is not completely loaded (compare with
the F7 screenshot) and that the edit boxes named "Lista" and "Ativo", at it's
bottom, are disabled. I can wait all day and it never finishes loading.
Comment 3 Marcelo 2007-12-25 17:28:46 EST
I do not expect you can debug this problem without access to the problematic web
page. However, maybe you can advise me on how to do it. I don't have the
slightest idea of what may be causing this weird behavior in F8, once I'm using
the same version of Firefox, flash-plugin and java that work ok in F7. What has
changed from F7 to F8 that may be causing this?
Comment 4 Christopher Aillon 2007-12-26 08:30:49 EST
(In reply to comment #3)
> What has changed from F7 to F8 that may be causing this?

Believe it or not, nothing.  They are using the same firefox code between each
release, so it's rather puzzling.  Since the sites use plugins, it's possible
perhaps that this is caused by the fact that plugins are now wrapped by
nspluginwrapper.  If you have this installed, can you please try the packages
and then restarting firefox to see if it helps?
Comment 5 Marcelo 2007-12-26 19:18:28 EST
When I first noticed the problem, I removed nspluginwrapper to test the site
without it, with no success. I have just installed this new version in the two
F8 boxes I have at home, but the problem persists. Tomorrow I'll try it at the
machine I use at work, but I have little hope it will work there.
Is there any other test I can run?
Comment 6 Marcelo 2007-12-27 06:42:46 EST
Tested the new nspluginwrapper at the F8 box I use at work, but the problem
persists. Also tried after uninstalling the nspluginwrapper package, with the
same results :(
Comment 9 Marcelo 2007-12-29 11:55:05 EST
Problem solved. It was java related. The application doesn't work with the
icedtea plugin and it was not working with Sun's java plugin because I had not
installed the compat-libstdc++ packages. Now that I installed them, the
application has loaded and run fine.
Comment 11 Christopher Aillon 2007-12-29 12:06:53 EST
Cool.  Glad it works now.

Note You need to log in before you can comment on or make changes to this bug.