This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 426769 - gparted cannot find /usr/bin/xxd (missing dependency: vim-common)
gparted cannot find /usr/bin/xxd (missing dependency: vim-common)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-25 23:44 EST by Stewart Adam
Modified: 2008-01-10 16:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 16:24:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image showing the failure (96.45 KB, image/png)
2007-12-25 23:44 EST, Stewart Adam
no flags Details

  None (edit)
Description Stewart Adam 2007-12-25 23:44:56 EST
Description of problem:
vim-common is not installed, gparted will fail to update the boot sector of an
NTFS partition when resizing it because /usr/bin/xxd is not found (see attached
image)

Version-Release number of selected component (if applicable):
gparted-0.3.3-14.fc9

How reproducible:
I haven't tried many times, but I'm assuming always

Steps to Reproduce:
1. Install gparted after a clean install
2. Grow an NTFS partition
  
Actual results:
xxd is not found and 0 writes are made with `dd'

Expected results:
gparted requires vim-common or packages /usr/bin/xxd
Comment 1 Stewart Adam 2007-12-25 23:44:56 EST
Created attachment 290392 [details]
Image showing the failure
Comment 2 Deji Akingunola 2007-12-28 00:38:46 EST
Thanks for reporting the bug. I'm going to add an explicit require on vim-common
in gparted rpm spec. 

Note You need to log in before you can comment on or make changes to this bug.