Bug 426791 - Tray monitor wont start and gives misleading error due perms
Tray monitor wont start and gives misleading error due perms
Status: CLOSED DUPLICATE of bug 426790
Product: Fedora
Classification: Fedora
Component: bacula (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 478772
  Show dependency treegraph
 
Reported: 2007-12-26 07:44 EST by Juha Tuomala
Modified: 2009-01-04 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 09:24:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2007-12-26 07:44:02 EST
Description of problem:
% bacula-tray-monitor
26-Dec 14:40 tray-monitor: ERROR TERMINATION at parse_conf.c:819
Config error: Cannot open config file "./tray-monitor.conf": Permission denied

% pwd
/home/tuju

# chown root:bacula /etc/bacula/tray-monitor.conf
% id tuju
uid=500(tuju) gid=500(tuju) groups=500(tuju),491(bacula) 
context=unconfined_u:system_r:unconfined_t:s0-s0:c0.c1023
% bacula-tray-monitor
Connecting to Director...

Version-Release number of selected component (if applicable):
bacula-traymonitor-2.0.3-11.fc8

I guess those files could be in bacula group out of the box
as nobody would like to add those users to root group anyway.
Now error implies that the problem is in user's home dir.
Comment 1 Gwyn Ciesla 2008-07-30 09:16:57 EDT
*** Bug 426790 has been marked as a duplicate of this bug. ***
Comment 2 Manuel Walz 2008-07-30 09:24:33 EDT

*** This bug has been marked as a duplicate of 426790 ***
Comment 3 Fedora Update System 2008-07-30 10:41:47 EDT
bacula-2.0.3-11.fc8.3 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-08-07 19:58:43 EDT
bacula-2.0.3-11.fc8.3 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.