Bug 426803 - Doing a yum install amarok pulls in kdebase
Doing a yum install amarok pulls in kdebase
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-26 11:53 EST by Sankarshan Mukhopadhyay
Modified: 2008-03-07 10:31 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.4.8-4.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 11:38:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sankarshan Mukhopadhyay 2007-12-26 11:53:51 EST
Description of problem:

yum install amarok pulls down as dependency fedorainfinity-kdm-theme

Version-Release number of selected component (if applicable):

 amarok                  i386       1.4.7-13.fc8

How reproducible:


Steps to Reproduce:
1. From GNOME session (with no kdebase installed) do yum install amarok
2.
3.
  
Actual results:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 amarok                  i386       1.4.7-13.fc8     updates            13 M
Installing for dependencies:
 fedorainfinity-kdm-theme  noarch     1.0.4-1.fc8      updates           1.1 M
 fftw                    i386       3.1.2-5.fc8      fedora            891 k
 htdig                   i386       3:3.2.0b6-13.fc8  updates           1.0 M
 kde-settings-kdm        noarch     3.5-35.fc8       updates            17 k
 kdebase                 i386       6:3.5.8-9.fc8    updates            27 M
 kdebase-libs            i386       6:3.5.8-9.fc8    updates           1.0 M
 libifp                  i386       1.0.0.2-6.fc8    fedora             51 k
 libmtp                  i386       0.2.2-2.fc8      updates            80 k
 libnjb                  i386       2.2.6-2.fc8      updates            72 k
 libofa                  i386       0.9.3-10.fc8     fedora             64 k
 libtunepimp             i386       0.5.3-9.fc8      fedora            370 k
 ruby                    i386       1.8.6.111-1.fc8  updates           512 k
 ruby-libs               i386       1.8.6.111-1.fc8  updates           1.7 M
 xorg-x11-xdm            i386       1:1.1.6-2.fc8    fedora            137 k



Expected results:

The KDM theme might not be required

Additional info:

Is this an example of a wrong Provides ?
Comment 1 Rex Dieter 2007-12-26 12:16:40 EST
amarok currently pulls in kdebase (afaict), which pulls in the rest of those deps.

I'll take a closer look to see if there's something we can do about that.
Comment 2 Rex Dieter 2008-02-21 15:21:13 EST
%changelog
* Thu Feb 21 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.4.8-4
- -konqueror subpkg (#426803)
Comment 3 Rex Dieter 2008-02-21 15:21:38 EST
cvs/rawhide updated, will make sure this gets included in the next pkg releaes
for f8.
Comment 4 Fedora Update System 2008-02-21 23:41:57 EST
amarok-1.4.8-4.fc8 has been submitted as an update for Fedora 8
Comment 5 Fedora Update System 2008-02-25 19:29:12 EST
amarok-1.4.8-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update amarok'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2030
Comment 6 Fedora Update System 2008-03-06 11:38:21 EST
amarok-1.4.8-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Laurent Rineau 2008-03-07 02:22:03 EST
Maybe amarok-konqueror should Obsolete the previous versions of amarok.
Comment 8 Rex Dieter 2008-03-07 08:49:56 EST
Laurent, glad you think so, because it does. :)
Comment 9 Laurent Rineau 2008-03-07 10:31:48 EST
Something must be buggy: i upgraded to amarok-1.4.8-4.fc8, from testing.. See 
my /var/log/yum.log:
  Feb 26 12:18:13 Updated: amarok.i386 1.4.8-4.fc8

However, that upgrade has not pulled amarok-konqueror. Once amarok has been 
pushed to updates, today, I have seen that there was now a subpackage for the 
konqueror extensions, and I have installed it today:
  Mar 07 08:21:43 Installed: amarok-konqueror - 1.4.8-4.fc8.i386

I do not see why the Obsoletes: has not pulled the new package. My Yum 
configuration makes Yum use Obsoletes, though:

lrineau@schtroumpf $ grep -i obsoletes /etc/yum.conf
obsoletes=1

Maybe a strange bug in Yum. Sorry for my remark. I should have had a look at 
the package.

Note You need to log in before you can comment on or make changes to this bug.