Bug 426810 - The working directory option isn't applied to livecd-creator
The working directory option isn't applied to livecd-creator
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-26 13:33 EST by Bruno Wolff III
Modified: 2008-05-23 06:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-23 06:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2007-12-26 13:33:39 EST
Description of problem:
When I used the --working-directory option to have scratch space on a file
system that had enough room while creating live media, I ran into a problem
because when revisor ran livecd-creator it didn't tell livecd-creator to use the
scratch area and it used its default of /var/tmp.

Version-Release number of selected component (if applicable):
2.0.5

How reproducible:
100%

Steps to Reproduce:
1. Run revisor with live media and a specified working directory
2.
3.
  
Actual results:
The working directory isn't used when livecd-creator is run.

Expected results:
That livecd-creator would use the specified working directory.

Additional info:
Comment 1 Jeroen van Meeuwen 2008-02-15 20:55:15 EST
Investigating
Comment 2 Jeroen van Meeuwen 2008-02-16 12:04:06 EST
What we're seeing is that the installroot setting for yum (/var/tmp/revisor by
default) is being used to loopmount the live media filesystem on. This isn't
consuming any space on the /var/tmp/ filesystem but I can see where it can work
confusing. Revisor might want to override the setting in the yum configuration
if the working_directory has been changed.
Comment 3 Jeroen van Meeuwen 2008-05-23 06:42:23 EDT
There's no way Revisor can change this on the fly. Please adjust the installroot
setting in the appropriate YUM configuration file (/etc/revisor/conf.d/) to
reflect the working directory you configure for Revisor

Note You need to log in before you can comment on or make changes to this bug.