Bug 426820 - Gnome fails to work at 8-bit colordepth
Gnome fails to work at 8-bit colordepth
Status: CLOSED DUPLICATE of bug 217636
Product: Fedora
Classification: Fedora
Component: gnome-common (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Toshio Ernie Kuratomi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-26 17:38 EST by Need Real Name
Modified: 2008-01-04 13:35 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 13:35:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-26 17:38:14 EST
Description of problem:
If I change my /etc/xorg.conf to call for an 8-bit colordepth or if I use vnc to
launch gnome with an 8-bit color depth, then gnome basically crashes. 

Gnome works fine with 16 or 24 bit colordepths.
Also, X itself works fine with just an 8 bit colordepth (e.g., when I use vnc
without launching gnome).

Bug buddy gave the following error message when I launched vnc with gnome
(though this may not be the root cause):

Distribution: Fedora release 8 (Werewolf)
Gnome Release: 2.20.2 2007-11-27 (Red Hat, Inc)
BugBuddy Version: 2.20.1

System: Linux 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: Permissive
Accessibility: Disabled
GTK+ Theme: Nodoka
Icon Theme: Fedora

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout:\
 0 it_real_value: 0 frequency: 0



----------- .xsession-errors (113 sec old) ---------------------
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
ALSA lib pcm_mmap.c:369:(snd_pcm_mmap) mmap failed: Invalid argument
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
error getting update info:  'NoneType' object has no attribute 'samearch'
--------------------------------------------------


Steps to reproduce:
1. First run 'vnc -depth 8' with the default~/.vnc/xstartup file where the
following 2 lines are commented out (this launches an X session without gdm/gnome)
 unset SESSION_MANAGER
 exec /etc/X11/xinit/xinitrc

This should work fine

2. Then run 'vnc -depth 8' with the lines uncommented. This should fail to
launch gnome properly.
Comment 1 Need Real Name 2007-12-28 08:06:18 EST
Error is as above, but just realized that the "error getting update info"
xsession messages may not be relevant since they have to do with an (unrelated)
bug in yum-updatesd
Comment 2 Toshio Ernie Kuratomi 2007-12-29 12:07:35 EST
This is definitely misfiled.  gnome-common is a package that aids in development
of gnome apps.  I'm on vacation right now but can ask the desktop team where it
should be filed after January 3rd if you aren't able to figure out where the bug
should be targeted before that.
Comment 3 Need Real Name 2007-12-29 17:42:24 EST
Sorry, I (mis)assumed that gnome-common was the underlying base. So I am not
sure where to refile this and would appreciate your help in figuring out where
to file.

Comment 4 Toshio Kuratomi 2008-01-04 13:35:34 EST
I asked around and found that this is a bug in cairo.

Here's our bug for the issue: https://bugzilla.redhat.com/show_bug.cgi?id=217636

and here's upstream's bug where the work is being done:
https://bugs.freedesktop.org/show_bug.cgi?id=4945

*** This bug has been marked as a duplicate of 217636 ***

Note You need to log in before you can comment on or make changes to this bug.