Bug 426835 - rdoc has a syntax error
rdoc has a syntax error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-27 00:09 EST by Conrad Meyer
Modified: 2008-06-24 23:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-24 23:01:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gem2ruby based srpm for the wmainfo-rb gem (9.18 KB, application/x-rpm)
2007-12-27 00:09 EST, Conrad Meyer
no flags Details
Contents of caboo.se URL above for future reference (1.47 KB, text/plain)
2008-01-10 18:22 EST, David Lutterkort
no flags Details

  None (edit)
Description Conrad Meyer 2007-12-27 00:09:55 EST
Description of problem:
rdoc seems to have a syntax error, this shouldn't happen.

Version-Release number of selected component (if applicable):
current

How reproducible:
always

Steps to Reproduce:
1. koji build --scratch dist-f9 rubygem-wmainfo-rb-0.4-1.fc8.src.rpm
2. check build.log
  
Actual results:
http://pastie.caboo.se/132182

Expected results:
Builds fine!

Additional info:
relevant srpm is attached.
Comment 1 Conrad Meyer 2007-12-27 00:09:55 EST
Created attachment 290436 [details]
gem2ruby based srpm for the wmainfo-rb gem
Comment 2 David Lutterkort 2008-01-10 18:22:27 EST
Created attachment 291337 [details]
Contents of caboo.se URL above for future reference
Comment 3 David Lutterkort 2008-01-10 18:27:17 EST
This looks like a ruby-rdoc bug to me, seems unrelated to rubygems.

Conrad: have you found any upstream info on this problem ?
Comment 4 Akira TAGOH 2008-01-10 18:53:51 EST
I apologize to make you in trouble for this issue. actually this is my fault and
was about to fix it. please wait for upcoming build.
Comment 5 Akira TAGOH 2008-01-10 22:55:26 EST
Fixed in 1.8.6.111-6.fc9.
Comment 6 Bug Zapper 2008-05-14 00:15:23 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.