Bug 426865 - Synaptics touchpad stops working intermittently
Synaptics touchpad stops working intermittently
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: synaptics (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-27 12:37 EST by Steevithak
Modified: 2008-06-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:57:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steevithak 2007-12-27 12:37:44 EST
Description of problem: At times the synaptics touchpad on my Dell Inspiron 8600
stops working. The pointer will freeze on the screen for 20 to 30 seconds and
then will start working again for a few seconds. The problem usually goes away
if I unplug the AC power and run on the battery. The problem usually returns
when the AC power is connected again. An external PS/2 or USB mouse works
normally, only the touchpad exhibits the problem. I've been running Fedora 7 on
this laptop since it was released and the problem only began within the last
week. I install Fedora updates as they are released, so I'm guessing one of the
recent updates broke something in kernel ACPI support or in the synaptics driver.


Version-Release number of selected component (if applicable):
synaptics-0.14.4-8.fc6
kernel-2.6.23.8-34.fc7



How reproducible: Often but not always reproducible when run on AC power. Very
rarely running on battery power.


Steps to Reproduce:
1. Connect AC power
2. Boot laptop
3. Try to use touchpad
  
Actual results:

Pointer alternately freezes and then works for a few seconds at a time

Expected results:

Touchpad should move the pointer normally

Additional info:

I've cleaned the touchpad, checked the physical wiring, tried the Dell pointer
diagnostics, swapped to an alternate HD with Windows XP. All indications are
that the touchpad hardware is working normally. The problem seems to be
something that changed in Fedora with a recent update.

If other information about the hardware or software is needed, let me know what
would be helpful.
Comment 1 Steevithak 2007-12-28 14:22:15 EST
Update: Based on suggestions I found from online searches, I tried booting with
"noacpi acpi=off pci=noacpi noapic nolapci lapci=off" but this had no effect on
the problem.

On the remote chance that this is a hardware problem I called Dell support. A
tech arrived today and replaced the palm rest and touchpad on the laptop. This
had no effect on the problem. He arranged to have a new motherboard sent out and
we'll try swapping that out when it arrives in a few days. I'll post an update
once I know the results.
Comment 2 Bug Zapper 2008-05-14 11:12:11 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2008-06-16 22:57:33 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.