Bug 426896 - [hpt3x2n]: LVM hangs for 5 minutes before continuing boot
[hpt3x2n]: LVM hangs for 5 minutes before continuing boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-27 23:47 EST by Gerry Reno
Modified: 2008-06-16 22:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages log (282.64 KB, text/plain)
2007-12-27 23:47 EST, Gerry Reno
no flags Details

  None (edit)
Description Gerry Reno 2007-12-27 23:47:34 EST
Description of problem:
Performed a yum upgrade on my servers today and I let the 2.6.23 kernel in.
Finally!  A non-FC6 kernel that will boot on my Highpoint Controllers.  The only
problem is that now my systems hang at Setting up Logical Volume Management for
about 5 minutes before continuing to boot.

And possibly related: both Firefox and Konqueror get segmentation faults when I
try to launch them.  All my icons have disappeared from every menu.  yum is now
getting some wierd error:
error: rpmdbNextIterator: skipping h#    3735 region trailer: BAD, tag 261289984
type 1048576 offset -3833856 count 1048576

Version-Release number of selected component (if applicable):
kernel is 2.6.23.8-34.f7


How reproducible:
every boot

Steps to Reproduce:
1. boot
2.
3.
  
Actual results:
as above

Expected results:
normal boot and behavior

Additional info:

related bugs for the hpt3x2n controller issues:
https://bugzilla.redhat.com/show_bug.cgi?id=245627
https://bugzilla.redhat.com/show_bug.cgi?id=245626
Comment 1 Gerry Reno 2007-12-27 23:47:34 EST
Created attachment 290482 [details]
messages log
Comment 3 Gerry Reno 2007-12-28 00:14:33 EST
This particular machine has an onboard HPT370A controller with a PCI HPT374
controller (No HPT302N)  6 channels/12 devices total.  I am only using the
Master connections so I have 6 drives connected.  I use mdadm RAID and not the
HW RAID.





































Comment 4 Gerry Reno 2007-12-28 09:38:55 EST
Ok, I fixed the segfaulting by performing:
/sbin/fixfiles relabel
This also fixed the yum problem.

Still no icons on menues.  Haven't figured out what could be the cause.

The long delay is being encountered in more places now:
At bootup when starting the firewall and when the login screen is supposed to
appear.

The drives seem very slow.  And I see there are timeouts related to the drives
in the messages log.

The system is not usable like this.  I'm hoping there is a fix for this problem.


Comment 5 Gerry Reno 2007-12-28 14:19:04 EST
The large PCI controller is a Highpoint RocketRAID 464 (4 channels/8 devices)
which I think uses the HPT374 chipset but you might need to check this.
Comment 6 Gerry Reno 2007-12-28 15:55:48 EST
I tried running the server for a while on 2.6.23 but it continually deteriorates
with more and more incidents of AVC violations and more and more delays
happening.  And right now after I've rebooted it several times the display
server is failing to start and keeps dumping me to a console prompt so I think
I'm going to go back to the FC6 kernel until the kernel team can sort out what
is happening.
Comment 7 Christopher Brown 2008-01-15 23:51:39 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

What is the latest on this - have any updates resolved the issue for you? Are
you able to attach dmesg output to this bug?
Comment 8 Christopher Brown 2008-02-15 21:59:06 EST
Closing INSUFFICIENT_DATA. Please re-open if this is still an issue for you on
the current F7 kernel. You may even wish to test with F8.
Comment 9 Wojciech Pilorz 2008-02-19 12:37:29 EST
(In reply to comment #8)
> Closing INSUFFICIENT_DATA. Please re-open if this is still an issue for you on
> the current F7 kernel. You may even wish to test with F8.

I have somewhat similar problem (deteriorating Fedora)
on my home system, which is PIII, Abit BX133 motherboard.
The system was Fedora8 installed on LVM /, /usr, etc partitions, with separate /boot
I have determined that the system replcates 4 bytes of data here and there
and a couple of kilobytes later some 4 bytes are removed.
I am going to open a separate bug for that, unless I am advised otherwise.

Wojtek
Comment 10 Wojciech Pilorz 2008-02-19 19:26:58 EST
I have filed bug #433557 [ https://bugzilla.redhat.com/show_bug.cgi?id=433557 ]
describing Fedora8 data corruption on my machine with HPT370 disk controller
with symptoms similar to what is described here (programs segfaulting, RPM
database corruption)
Comment 11 Gerry Reno 2008-04-04 12:16:04 EDT
This issue is still a problem.  I cannot get a 2.6.23 kernel to run reliably 
on any machine with a HighPoint controller either onboard or PCI card based.
It does not matter what version of Fedora is used.  It is a kernel issue.

Comment 12 Bug Zapper 2008-05-14 11:12:19 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Bug Zapper 2008-06-16 22:57:41 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.