Bug 426900 - Pirut crashes when running AddRemove Programs
Pirut crashes when running AddRemove Programs
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-28 02:46 EST by John Perczyk
Modified: 2007-12-28 08:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-28 08:46:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Perczyk 2007-12-28 02:46:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
When I click on the Icon I get the following exception report:

Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 479, in main
    pm.run()
  File "/usr/sbin/pirut", line 407, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 423, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x9a28b4c>
commands: None
opts: None




Version-Release number of selected component (if applicable):
pirut-1.3.28-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. Click Applications
2. Click Add/Remove software
3.

Actual Results:
Package manager briefly appears and then the exception box appears

Expected Results:
Add/remove software package manager should have loaded (it has worked before).

Additional info:
Recently updated to latest release of Fedora
Comment 1 Jeremy Katz 2007-12-28 08:46:57 EST

*** This bug has been marked as a duplicate of 421961 ***

Note You need to log in before you can comment on or make changes to this bug.