Bug 426918 - Make cyloadrules on upgrade
Summary: Make cyloadrules on upgrade
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cyphesis (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Wart
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-28 12:45 UTC by Alexey Torkhov
Modified: 2008-07-26 06:06 UTC (History)
0 users

Fixed In Version: 0.5.15-8.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-14 04:20:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexey Torkhov 2007-12-28 12:45:13 UTC
Description of problem:
Rpm doesn't do cyloadrules on upgrade.
Because of that cyphesis uses old rules which has bugs fixed in new versions.
Like this one: https://bugs.launchpad.net/cyphesis/+bug/179039

Version-Release number of selected component (if applicable):
cyphesis-0.5.15-3.fc8

Comment 1 Wart 2007-12-28 16:45:15 UTC
You're right.  It looks like cyloadrules is only getting called the first time
the database is created.  Do you think it would be better to run cyloadrules
every time the server starts, or only when the server is upgraded?

Comment 2 Alexey Torkhov 2007-12-28 17:18:41 UTC
It should be also runned on rpm install, not just upgrade - after uninstalling
you're leaving database intact.

Um, I don't know. May be running it only on install/upgrade is better.

Comment 3 Wart 2007-12-29 04:23:22 UTC
The reason we can't do it in the rpm script during install/upgrade time is
because we can't be guaranteed that postgres is running.  If we want to limit it
to only during upgrades/installs, then we would have to make the rpm create some
sort of trigger, such as setting a flag in /etc/sysconfig/cyphesis.  The init.d
script for cyphesis would then check for this trigger, run cyloadrules, and then
reset the trigger.

Comment 4 Wart 2008-01-02 23:07:24 UTC
I have a patch to fix this and will post a link to the rpm for you to try once
I've done a little more testing on it.

Comment 5 Wart 2008-06-06 17:39:11 UTC
Changing Version to F9.  I can push this fix to F8 if there is still demand for it.

Comment 6 Fedora Update System 2008-06-06 17:41:40 UTC
cyphesis-0.5.15-7.fc9 has been submitted as an update for Fedora 9

Comment 7 Fedora Update System 2008-06-10 03:12:37 UTC
cyphesis-0.5.15-8.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cyphesis'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5107

Comment 8 Fedora Update System 2008-06-14 04:20:19 UTC
cyphesis-0.5.15-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2008-07-26 06:06:28 UTC
cyphesis-0.5.15-8.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.