Bug 426921 - 'NoneType' object has no attribute 'samearch'
'NoneType' object has no attribute 'samearch'
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-28 08:14 EST by Need Real Name
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-28 08:47:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-28 08:14:00 EST
Description of problem:
My syslog is full of error messages of type:
yum-updatesd-helper: error getting update info: 'NoneType' object has no
attribute 'samearch'

Per the following reference,
http://forums.fedoraforum.org/forum/showthread.php?t=176323,
the error appears to be in  /usr/lib/yum-plugins/priorities.py (part of
yum-priorities package) where the line:
 if opts.samearch:
should be replaced by something like:
 if opts and opts.samearch:
Comment 1 Jeremy Katz 2007-12-28 08:47:07 EST

*** This bug has been marked as a duplicate of 421961 ***

Note You need to log in before you can comment on or make changes to this bug.