Bug 426965 - Pulseaudio complains (wrongly) that it's already running
Pulseaudio complains (wrongly) that it's already running
Status: CLOSED DUPLICATE of bug 425763
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-28 19:04 EST by Bastien Nocera
Modified: 2008-02-15 11:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 11:46:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
details about pid file and /var/log/messages (1.12 KB, text/plain)
2008-02-07 05:37 EST, Michael Schwendt
no flags Details

  None (edit)
Description Bastien Nocera 2007-12-28 19:04:27 EST
pulseaudio-0.9.8-4.fc9

1. Start your machine up
2. Have it die because you run out of battery
3. Reboot
4. See that sound isn't working

$ strace -v pulseaudio
[...]
mkdir("/tmp/pulse-hadess", 0700)        = -1 EEXIST (File exists)
umask(022)                              = 077
getuid32()                              = 500
getgid32()                              = 500
chown32("/tmp/pulse-hadess", 500, 500)  = 0
chmod("/tmp/pulse-hadess", 0700)        = 0
lstat64("/tmp/pulse-hadess", {st_dev=makedev(8, 2), st_ino=3552377,
st_mode=S_IFDIR|0700, st_nlink=2, st_uid=500, st_gid=500, st_blksize=4096,
st_blocks=8, st_size=4096, st_atime=2007/09/27-14:30:57,
st_mtime=2007/12/23-10:59:26, st_ctime=2007/12/28-00:06:08}) = 0
open("/tmp/pulse-hadess/pid", O_RDWR|O_CREAT|O_NOCTTY|O_LARGEFILE|O_NOFOLLOW,
0600) = 3
fcntl64(3, F_SETLKW64, {type=F_WRLCK, whence=SEEK_SET, start=0, len=0},
0xbf93c2e4) = 0
fstat64(3, {st_dev=makedev(8, 2), st_ino=3547557, st_mode=S_IFREG|0600,
st_nlink=1, st_uid=500, st_gid=500, st_blksize=4096, st_blocks=16, st_size=5,
st_atime=2007/12/27-20:25:21, st_mtime=2007/12/23-10:59:14,
st_ctime=2007/12/23-10:59:14}) = 0
read(3, "2903\n", 19)                   = 5
read(3, "", 14)                         = 0
kill(2903, SIG_0)                       = 0
ioctl(2, SNDCTL_TMR_TIMEBASE or TCGETS, {c_iflags=0x6d02, c_oflags=0x5,
c_cflags=0x4bf, c_lflags=0x8a3b, c_line=0,
c_cc="\x03\x1c\x7f\x15\x04\x00\x01\xff\x11\x13\x1a\xff\x12\x0f\x17\x16\xff\x00\x00"})
= 0
write(2, "E: pid.c: \33[1;31mDaemon already "..., 45E: pid.c: Daemon already
running.
) = 45
fcntl64(3, F_SETLKW64, {type=F_UNLCK, whence=SEEK_SET, start=0, len=0},
0xbf93c384) = 0
close(3)                                = 0
ioctl(2, SNDCTL_TMR_TIMEBASE or TCGETS, {c_iflags=0x6d02, c_oflags=0x5,
c_cflags=0x4bf, c_lflags=0x8a3b, c_line=0,
c_cc="\x03\x1c\x7f\x15\x04\x00\x01\xff\x11\x13\x1a\xff\x12\x0f\x17\x16\xff\x00\x00"})
= 0
write(2, "E: main.c: \33[1;31mpa_pid_file_cr"..., 51E: main.c:
pa_pid_file_create() failed.
) = 51
exit_group(1)                           = ?

$ ls /tmp/pulse-hadess/
native  pid     
$ ls /tmp/pulse-hadess/pid 
8.2k /tmp/pulse-hadess/pid
$ cat /tmp/pulse-hadess/pid 
2903
$ ps aux | grep 2903
hadess    2903  0.0  1.2 120760 25512 ?        S    Dec27   0:06 nautilus
--no-default-window --sm-client-id default3
hadess    6596  0.0  0.0   4064   688 pts/0    R+   00:06   0:00 grep 2903

Pulseaudio doesn't start, and I have no sound because nautilus happens to be
running with the same PID Pulseaudio used to have in a previous run.
Comment 1 Michael Schwendt 2008-02-07 05:37:37 EST
Created attachment 294197 [details]
details about pid file and /var/log/messages

The same I've run into again with up-to-date F8.
Here are some details. Perhaps important, pulseaudio got the
same PID before it failed.
Comment 2 Lennart Poettering 2008-02-15 11:46:33 EST

*** This bug has been marked as a duplicate of 425763 ***

Note You need to log in before you can comment on or make changes to this bug.