Bug 426986 - avahi-dnsconf tries to start before avahi-daemon by default
avahi-dnsconf tries to start before avahi-daemon by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Bacovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 06:44 EST by Steven Côté
Modified: 2008-03-26 20:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 20:33:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steven Côté 2007-12-29 06:44:14 EST
Description of problem:
After installing avahi-daemon and avahi-dnsconf, in runlevel 5 the initscripts
try to start avahi-dnsconf before avahi-daemon (S92 vs S98). Since avahi-dnsconf
relies on avahi-daemon, it fails to start.

Version-Release number of selected component (if applicable):
0.6.21-6.fc8 (both components)

How reproducible:
always

Steps to Reproduce:
1. install avahi and avahi-dnsconfd
2. restart computer
  
Actual results:
avahi-dnsconf is not running. It works fine if manually started.

Expected results:
Both avahi-dnsconf and avahi-daemon should be running

Additional info:
I manually changed the start order of these two at run level 5 so that
avahi-dnsconf starts after avahi-daemon and it starts fine now.
Comment 1 Steven Côté 2007-12-30 05:16:18 EST
I'm changing the component to Avahi, it seems more appropriate.
Comment 2 Lennart Poettering 2008-03-26 20:33:03 EDT
avahi-daemon's chkconfig line is now:

# chkconfig: 345 96 02

avahi-dnsconfd's chkconf line is now:

# chkconfig: - 96 02

I thus believe this problem doesn't exist anymore, because both are started at
prio 96 and n is alphabetically after a.

Closing bug.

Note You need to log in before you can comment on or make changes to this bug.