Bug 426996 - need quick install guide for booting off of usb stick and installing from network
need quick install guide for booting off of usb stick and installing from net...
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: documentation-guide (Show other bugs)
devel
All Linux
low Severity low
: ---
: ---
Assigned To: Paul W. Frields
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 13:12 EST by Martin VanWinkle
Modified: 2007-12-29 17:37 EST (History)
1 user (show)

See Also:
Fixed In Version: 8.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 17:37:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin VanWinkle 2007-12-29 13:12:41 EST
Greetings.  I'm currently a debian person trying to install fedora over the
network.  I was able to find that putting diskboot.img on a usb stick, booting
that up and choosing http as the package stuff would get me where I'm going. 
That's good.  What I wasn't able to find was a way to quickly search for
"network install fedora usb stick", and I think some quick documentation
somewhere with the right keywords would be beneficial.

Here's some stub documentation (i know it's not great, currently at my family's
house trying to unbrick a laptop with a busted cdrom drive).

Go to some webby place that has fedora.
Download Fedora/i386/os/images/diskboot.img
cat diskboot.img > /dev/sdb (or whatever the usb stick is)
If you wanna use dd, be my guest.

Boot up, go through some options etc, choose http as an option
(because I dont normally use fedora I wasnt sure if the boot image that I had
selected would boot and would give me the ability to select http as the install
source).
Enter the site name and link to the fedora installs up to 8/Fedora/i386/os/
Fudge the URL until it can actually download the file it wants.

profit.

Other than that, no complaints.  The net install is running fairly slow; I was
able to get 300k/s off of the site that I'm installing from and the blinken
lichten hint toward something happening, but it just says "Starting install
process".  It would be cool if there was some way to see what it's doing aside
from looking at the traffic on the wire.
Comment 1 Martin VanWinkle 2007-12-29 16:55:28 EST
During a network install, if it stays on:  "Starting install process" for a long
time, the thing may have stalled.
Comment 2 Martin VanWinkle 2007-12-29 16:56:00 EST
And by a long time I mean I had the thing on for 4 hours.  Rebooted the machine,
started the installation over, and then it spent probably less than 10 minutes
on that thing.
Comment 3 Paul W. Frields 2007-12-29 17:37:45 EST
This information appears prominently in Chapters 2, 3, and 6 of the Fedora 8
Installation Guide -- both instructions on making a bootable USB stick, and on
using a network source for installation.

As for the speed of installation, you may want to choose a mirror geographically
close to you or which gives you generally good response time.  As mentioned in
Chapter 6 of the Installation Guide, you can go to our mirror list to find a
mirror close to you.

Note You need to log in before you can comment on or make changes to this bug.