Bug 426997 - clamav packages badly broken, do not even start daemon
clamav packages badly broken, do not even start daemon
Product: Fedora EPEL
Classification: Fedora
Component: clamav (Show other bugs)
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-29 13:48 EST by Florin Andrei
Modified: 2008-01-05 08:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-30 19:30:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2007-12-29 13:48:42 EST
Description of problem:
I am trying to use clamd with amavis and Postfix. Amavis is supposed to pass the
attachments to clamd via a Unix socket. That's how it worked for a while with
the clamav packages made by Dag Wieers, no problems at all.

Today I uninstalled Dag's packages and installed the EPEL ones instead. Big mistake.

The /etc/init.d stuff is badly broken. There isn't even a script proper, there's
just a symlink to a wrapper. The wrapper file is not in the recognized init.d
scripts style.

There's a clamd.init file somewhere in /usr/share, but there's a <SERVICE> tag
in it that needs to be adjusted. That same tag is somehow propagated in the
clamd.sysconfig file and possibly in a buch of other places. No explanation for
its purpose. The way it currently is, the scripts just fail.

Why is the package failing to work after install? Why it doesn't just work? Why
the over-engineered customization with <SERVICE>?

There's a bunch of CLAMD_SERVICE variables sprinkled all over the place in the
wrapper script, that appears to be related to the <SERVICE> tag. Holy freaking
bejesus. Why should I care about that?
If I wanted to care about that, I would install clamav from source, thank you
very much.

After installing clamav-server and the related packages, the stuff should Just
Work (TM). It should not require dozens of obscure tweaks. What's the point in
having a package otherwise?

The Dag packages simply worked, as they always do, perhaps with some small
adjustments in the .conf file. I uninstalled them today, due to a conflict with
EPEL and thought I could use the EPEL packages instead. How silly of me. If I
can't figure out how to make the EPEL stuff work, I'll have to go back to Dag's
packages and set up all kinds of exceptions in yum, to work around the broken
EPEL packages. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install clamav
2.try and run the daemon as a service
Actual results:

Expected results:
daemon should run

Additional info:
Comment 1 Steven Pritchard 2007-12-30 19:30:11 EST
It's not that I don't empathize (I definitely do), and I'll freely admit that
some things in the clamav packages really should be reconsidered (for example,
installing clamav-update should definitely give you a working freshclam).  That
said, a) this is Enrico's package, b) it's worked like this since the fedora.us

The EPEL clamav package is (nearly) identical to the stock Fedora package.  It
is in no way compatible with the one from Dag's repo.  Unfortunately, with it
just finally showing up in EPEL, I can't recommend switching to our amavisd-new,
etc., but ultimately that would be the right answer.  (Well, that, or keep using
Comment 2 Steven Pritchard 2007-12-30 19:43:27 EST
BTW, as proof we've been through all of this before, see the following thread:


Note You need to log in before you can comment on or make changes to this bug.