Bug 427002 - pirut crashes as soon as I enter the root password and "exception occurred" screen
pirut crashes as soon as I enter the root password and "exception occurred" s...
Status: CLOSED DUPLICATE of bug 421961
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 16:47 EST by Jeff Alwine
Modified: 2007-12-30 12:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-29 17:35:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Alwine 2007-12-29 16:47:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc7 Firefox/2.0.0.10

Description of problem:
No options, it tells me there are updates avaiable, I click the "see updates" button: it comes up and prompts me for the root password, when I enter it then I get the "exception occurred" window. WWith further checking it does the same if I create a telnet window, log in as root, and run pirut from the command line.

Version-Release number of selected component (if applicable):
pirut-1.3.28-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. See problem description above.
2.
3.

Actual Results:
Igot an "exception occurred" window

Expected Results:
I should have gotten a list of available updates.

Additional info:
Below is the information from the "exception occurred" window.

Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType' object has no attribute 'samearch'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 611, in <module>
    main()
  File "/usr/sbin/pup", line 607, in main
    pup.run()
  File "/usr/sbin/pup", line 447, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 262, in doRefresh
    pbar = self.doRefreshRepos(destroy=False)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 396, in _getSacks
    self.plugins.run('exclude')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x97144cc>
commands: None
opts: None
Comment 1 Jon Stanley 2007-12-29 17:18:49 EST
I'm working on the bug triage project, not a developer of pirut - but here's my
interpretation of this..

This sounds almost like a yum metadata error.   Have you tried either a 'yum
clean all' from the command line (Applications/System/Terminal - then 'su -' to
become root), or a simple 'yum update' or 'yum install <whatever>'.
Comment 2 Jeremy Katz 2007-12-29 17:35:17 EST

*** This bug has been marked as a duplicate of 421961 ***
Comment 3 Jeff Alwine 2007-12-30 09:02:39 EST
From Jeff - Jon Stanley suggested I do a yum clean all - this did not fix pirut
- but he also suggested I do a yum update which updated - well see below. pirut
now appears to be working. Thanks for the advice.

[root@localhost ~]# yum update
Loading "priorities" plugin
406 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package yum-priorities.noarch 0:1.1.9-2.fc7 set to be updated
---> Package imlib.i386 1:1.9.15-6.fc7 set to be updated
---> Package gxine.i386 0:0.5.11-14.fc7 set to be updated
---> Package gimp-libs.i386 2:2.4.3-1.fc7 set to be updated
---> Package gimp.i386 2:2.4.3-1.fc7 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 gimp                    i386       2:2.4.3-1.fc7    updates            14 M
 gimp-libs               i386       2:2.4.3-1.fc7    updates           574 k
 gxine                   i386       0.5.11-14.fc7    updates           468 k
 imlib                   i386       1:1.9.15-6.fc7   updates           420 k
 yum-priorities          noarch     1.1.9-2.fc7      updates           8.7 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       5 Package(s)
Remove       0 Package(s)

Total download size: 15 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): gimp-2.4.3-1.fc7.i 100% |=========================|  14 MB    00:50
(2/5): gimp-libs-2.4.3-1. 100% |=========================| 574 kB    00:01
(3/5): gxine-0.5.11-14.fc 100% |=========================| 468 kB    00:02
(4/5): imlib-1.9.15-6.fc7 100% |=========================| 420 kB    00:02
(5/5): yum-priorities-1.1 100% |=========================| 8.7 kB    00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : yum-priorities               ####################### [ 1/10]
  Updating  : gimp-libs                    ####################### [ 2/10]
  Updating  : imlib                        ####################### [ 3/10]
  Updating  : gxine                        ####################### [ 4/10]
  Updating  : gimp                         ####################### [ 5/10]
  Cleanup   : yum-priorities               ####################### [ 6/10]
  Cleanup   : imlib                        ####################### [ 7/10]
  Cleanup   : gxine                        ####################### [ 8/10]
  Cleanup   : gimp-libs                    ####################### [ 9/10]
  Cleanup   : gimp                         ####################### [10/10]

Updated: gimp.i386 2:2.4.3-1.fc7 gimp-libs.i386 2:2.4.3-1.fc7 gxine.i386
0:0.5.11-14.fc7 imlib.i386 1:1.9.15-6.fc7 yum-priorities.noarch 0:1.1.9-2.fc7
Complete!
[root@localhost ~]# pirut
Loading "priorities" plugin
406 packages excluded due to repository priority protections
Comment 4 Jon Stanley 2007-12-30 12:19:28 EST
Yep, as noted in the bug that Jeremy marked this a duplicate of, yum-priorities
(which was updated in your yum update above) had issues with using a non-CLI
front-end, and that bug was squashed.

Note You need to log in before you can comment on or make changes to this bug.