Bug 427014 - system-config-selinux confusion make system unbootable
system-config-selinux confusion make system unbootable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 19:17 EST by Björn Sund
Modified: 2008-01-03 10:59 EST (History)
0 users

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 10:59:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn Sund 2007-12-29 19:17:42 EST
Description of problem:
Slightly confused when using system-config-selinux. I disabled it a while ago
and decided to enable it again today. So I put it into enforcing as it used to
be, it said that I would need to relabel, so I reboot and not much go right. 

Seems most stuff wont be able to do their things because of restrictions. I
didn't manage to boot so needed to go rescue-cd.

Version-Release number of selected component (if applicable):
GNOME SELinux Management Tool 5 (system up to date at 29/12/07)

Steps to Reproduce:
1. Disable SELinux and reboot.
2. Enable enforcing SELinux, mark relabel and reboot.
  
Actual results:
System won't boot.

Expected results:
System would boot.

Additional info: It wouldn't relabel with SELinux disabled so i just put it in
enforcing thinking it would sort it out. Maybe some more clarifying in the gui
would help. :)
Comment 1 Daniel Walsh 2007-12-31 09:11:58 EST
You probably need to reboot in permissive mode.  

With the latest updates of selinux policy this should not though.  

Note You need to log in before you can comment on or make changes to this bug.