Bug 427015 - No way to record monitors with reduced blanking
No way to record monitors with reduced blanking
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-29 19:48 EST by Michael De La Rue
Modified: 2008-01-17 06:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 08:14:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael De La Rue 2007-12-29 19:48:41 EST
Description of problem:
Certain monitors (e.g. 1920 x 1200 sized LCD) require the use of 
  Option      "ReducedBlanking"
in the "Monitors" section of xorg.conf to work with normal video cards.  This
allows them to work with their full resolution with a lower clock speed.  

Version-Release number of selected component (if applicable):
2.0.7

How reproducible:
every time

Steps to Reproduce:
1. read format of file
2. realise that  <Manufacturer>; <Monitor name>; <EISA ID (if any)>; <horiz sync
in \
#   Khz>; <vert sync in Hz>; DPMS support 
 doesn't let you include ReducedBlanking
  
Actual results:
monitor data is too simplistic

Expected results:
monitor data should allow recording of monitor options  

Additional info:
see slso bug #427012
Comment 1 Karsten Hopp 2008-01-16 08:14:31 EST
I'm closing this as WONTFIX for the following reasons:
- this option seems to depend on the combination of video card and monitor,
  some combinations need it, others work just fine without. 
- Many other distributions use our MonitorsDB and changing the format will most
likely break their (and our) tools that use it.
- MonitorsDB will most likely become obsolete in the near future. 
Comment 2 Michael De La Rue 2008-01-16 15:08:37 EST
In defense of the proposal; reduced blanking is a perfectly clearly defined VESA
standard feature of the monitor alone.  It may be supported / used only by
certain video cards but it's an actual feature of the video signal that you are
allowed to feed the monitor (e.g. LCD monitors can have reduced blanking since
they have circuitry writing to individual pixels, CRT can't since they need time
for the beam to fly back to the left of screen).  

What's the new / proposed alternative for MonitorsDB; where can we find it?
Comment 3 Karsten Hopp 2008-01-17 06:27:54 EST
AFAIK the xorg folks are working on automation of this stuff so that it won't be
necessary to configure this in xorg.conf anymore (the whole monitor section)

Note You need to log in before you can comment on or make changes to this bug.