Bug 427028 - ufraw fails to open correctly sized windows
Summary: ufraw fails to open correctly sized windows
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ufraw
Version: 8
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 427096
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-30 12:19 UTC by Steve Milner
Modified: 2008-01-11 22:29 UTC (History)
0 users

Fixed In Version: 1.5.0-1.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-11 22:18:30 UTC
Type: ---


Attachments (Terms of Use)

Description Steve Milner 2007-12-30 12:19:36 UTC
Description of problem: 
ufraw opens an image in a scrollable window, the correct behaviour: When
openning a file UFRaw tries to open the largest window that can contain the
image using an integer shrink factor.

I have raised this with the sourceforge bug reporter for ufraw but it seems the
problem lies with the fc8 package: see -
http://sourceforge.net/tracker/index.php?func=detail&aid=1857162&group_id=127649&atid=709086


Version-Release number of selected component (if applicable):
ufraw-common-0.13-2.fc8
ufraw-0.13-2.fc8
ufraw-gimp-0.13-2.fc8

How reproducible:
Always

Steps to Reproduce:
1.Open a raw camera image eg .raw from a Panasoniz FZ50 or a .cr2 from a Canon 400D

Actual results:
The image does not appear in the largest widow possible with an integer shrink
factor


Expected results:
The image should appear in the largest window possible with an intetger shrink
factor

Additional info: The images I am using are 10MP images. The shrink factor
calculated by the package is correct, the window size is not.

A comment from the ufraw bug dialogue I raises:
Looking at the FC8 package I see that they are using a
ufraw-0.13-scrollable-preview.patch.

So it is their code and their bug. I don't see the logic in this patch
when UFRaw already supports scolling through GtkImageView.

Regards,
Steve

Comment 1 Nils Philippsen 2007-12-31 13:36:55 UTC
The problem is that gtkimageview isn't packaged for Fedora (yet), it's to be
reviewed, see bug #427096. Would you do the review?

I'll check if there is a way to improve the offending patch in the meantime.
Leaving it out (without using gtkimageview) isn't an option because then the
ufraw window wouldn't be resizeable at all.

Comment 2 Steve Milner 2007-12-31 22:14:11 UTC
I would be willing to do the review, but before I commit, can you give me a url
as to what is required. I need to check that I have the relevant skills to be
able to perform this task before I commit.

I will post this reply back to the ufraw bug report.

Thanks for the reply, I now understand the situation much better.

Steve

Comment 3 Nils Philippsen 2008-01-01 14:32:20 UTC
Thanks for your offer, but Manuel Wolfshant already did a very quick review. I'm
waiting for CVS to be set up, then I can build against the library and drop the
offending patch.

How to do reviews (we'd be glad if you would help in that area[1]) and what the
prerequisites are is described in the Fedora Project wiki[2].

[1]: unassigned outstanding reviews: 
http://fedoraproject.org/wiki/PackageMaintainers/UnassignedReviewRequests --
this redirects to the open Bugzilla tickets
[2]: http://fedoraproject.org/wiki/PackageReviewProcess

Have a good year 2008!

Comment 4 Fedora Update System 2008-01-03 01:41:33 UTC
gtkimageview-1.5.0-1.fc8, ufraw-0.13-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtkimageview ufraw'

Comment 5 Fedora Update System 2008-01-03 01:49:03 UTC
ufraw-0.13-3.fc7, gtkimageview-1.5.0-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ufraw gtkimageview'

Comment 6 Fedora Update System 2008-01-11 22:18:29 UTC
gtkimageview-1.5.0-1.fc8, ufraw-0.13-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2008-01-11 22:29:14 UTC
ufraw-0.13-3.fc7, gtkimageview-1.5.0-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.