Bug 427040 - RRDp.pm does not return when error_mode is 'catch' and an error occurs
RRDp.pm does not return when error_mode is 'catch' and an error occurs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rrdtool (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 10:51 EST by Martin Poole
Modified: 2008-01-02 20:43 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 11:03:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2007-12-30 10:51:40 EST
Description of problem:

There is a problem in RRDp.pm when the error_mode is set to catch and an error
occurs.

Since the behaviour of rrdtool in pipe mode describes the result of a command
being one of two things

   1. OK followed by the timings
   2. ERROR followed by a relevant string 

the RRDp needs to take into account that the read sequence is complete in either
case.

Unfortunately the ERROR case returns to the read loop rather than returning.
This results in the calling program hanging.

Version-Release number of selected component (if applicable):

rrdtool-1.3-0.1.beta1.fc8

How reproducible:

Always.

Steps to Reproduce:
1. attempt to update an rrd with an old timestamp
2.
3.
  
Actual results:

code hangs in module

Expected results:

returns undef

Additional info:

Upstream report http://oss.oetiker.ch/rrdtool-trac/ticket/118

Upstream fixed commited in
http://oss.oetiker.ch/rrdtool-trac/browser/trunk/program/bindings/perl-piped/RRDp.pm?rev=1209


Revised code available in beta3 package.
Comment 1 Jarod Wilson 2008-01-02 11:03:34 EST
Just updated to beta3 in rawhide, will push for f8 soon as well.
Comment 2 Fedora Update System 2008-01-02 20:43:36 EST
rrdtool-1.3-0.4.beta3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.