Bug 427043 - module-alsa-sink.c: Error opening PCM device hw:0: Device or resource busy
module-alsa-sink.c: Error opening PCM device hw:0: Device or resource busy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 11:48 EST by udo
Modified: 2008-02-28 13:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 13:24:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udo 2007-12-30 11:48:42 EST
Description of problem:

module-alsa-sink.c: Error opening PCM device hw:0: Device or resource busy
occurs in the log after a while;

Version-Release number of selected component (if applicable):

Current Fedora 8. 0.9.7

How reproducible:


Steps to Reproduce:
Run the system for a while. After some time (might be days) sounds stop wkroing,
software hangs when sounds need to be played (Thunderbird when new mail arrives,
xine when reconfiguring and mail arrives, xmms when playing music and mail
arrives, etc)
  
Actual results:
Some sounds stop working, sometimes errors are logged.

Expected results:
100% perfect working audio. Why can't I just play *ALL* sound via alsa when I
don't need pulseaudio?

Additional info:
Comment 2 udo 2008-01-06 13:57:44 EST
Just happened again:

MP3 playing in xmms.
Mail arrives. Thunderbird cannot play the sound.
So Thunderbird is hanging and cannot be brought into the foreground.
xmms is using alsa.
Thunderbird uses whatever it is configured with by Redhat. (I cannot choose a
specific API or device in Thunderbird via normal means)
How can I fix this error message and the system's behaviour that comes with it?
I would think that it is either a simple to fix error on my side or a very big
issue but where are the other bug entries?
Comment 3 Lennart Poettering 2008-02-15 11:46:05 EST
Some other app seems to be blocking access to your audio device, so that PA
cannot access it. Use fuser -v /dev/snd/* to find out which one.
Comment 4 udo 2008-02-15 12:56:24 EST
Installing PA support for a few apps has made the error go away, as it appears.
Comment 5 Lubomir Kundrak 2008-02-28 13:24:16 EST
Furthermore noone forces you to use PA. you can uninstall it, or at least the
alsa plugin. Better solution is to use it and avoid broken sound apps.

Note You need to log in before you can comment on or make changes to this bug.