Bug 427064 - Enhance message when running rpm as non-root user
Enhance message when running rpm as non-root user
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 14:55 EST by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-01 06:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2007-12-30 14:55:51 EST
Description of problem:

The message that a user gets when running rpm as non-root user can be improved

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. rpm -e <foo> as non-root user

  
Actual results:

You will get error: can't create transaction lock on /var/lib/rpm/__db.000

Expected results:

Something more nicer like "You need to be root to perform this command." which
is the output from yum.
Comment 1 Panu Matilainen 2008-04-01 06:43:03 EDT
Fixed upstream to log the reason too, so regular user would typically get:
error: can't create transaction lock on /var/lib/rpm/__db.000 (Permission denied)

Rpm doesn't require root for transaction etc locks, it just needs write
permissions to the directory so claiming root is required would be wrong. 

Note You need to log in before you can comment on or make changes to this bug.