Bug 427070 - Alexandria fails to start
Alexandria fails to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: alexandria (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 16:12 EST by James Begley
Modified: 2008-01-02 20:30 EST (History)
0 users

See Also:
Fixed In Version: 0.6.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 20:30:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Begley 2007-12-30 16:12:32 EST
Description of problem: Alexandria fails to start.

Version-Release number of selected component (if applicable): 
alexandria-0.6.2-1.fc8


How reproducible: Every time


Steps to Reproduce:
1. start alexandria (eg from the bash shell install alexandria (+deps) and type 
alexandria)
2.
3.
  
Actual results: The following error message gets spewed to the screen
[james@jumbovaio ~]$ alexandria 
/usr/lib/ruby/site_ruby/1.8/alexandria/ui/completion_models.rb:56:in `gm': time 
out of range (ArgumentError)
        from /usr/lib/ruby/site_ruby/1.8/alexandria/ui/
completion_models.rb:56:in `get_all_contacts'
        from /usr/lib/ruby/site_ruby/1.8/alexandria/ui/completion_models.rb:56
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/lib/ruby/site_ruby/1.8/alexandria/ui.rb:24
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/lib/ruby/site_ruby/1.8/alexandria.rb:119
        from /usr/bin/alexandria:4:in `require'
        from /usr/bin/alexandria:4


Expected results:
Alexandria should start and show the main 'library' screen.

Additional info:
Downgrading from version 0.6.2-1.fc8 to version 0.6.2-0.6.b2.fc8 'solves' the 
problem.
Comment 1 James Begley 2007-12-30 17:53:09 EST
Umm .. actually I lied.  Downgrading to version 0.6.2-0.6.b2.fc8 doesnt solve 
the problem.  That version used to work though - I was using it 2 weeks ago 
before the latest updates came through.  Perhaps it's a wider Ruby issue?
Comment 2 Mamoru TASAKA 2007-12-30 21:01:00 EST
The reason needs investigating, however would you check if
0.6.2-2.fc8 solves your problem?

(Not pushed to testing or stable yet, please download it from
 http://koji.fedoraproject.org/packages/alexandria/0.6.2/2.fc8/ )
Comment 3 James Begley 2007-12-31 04:03:30 EST
Yep, version 0.6.2-2.fc8 has fixed things.

[james@jumbovaio ~]$ alexandria 
W, [2007-12-31T08:47:58.336154 #3819]  WARN -- : time out of range

Thanks.
Comment 4 Mamoru TASAKA 2007-12-31 04:18:56 EST
(In reply to comment #3)
> Yep, version 0.6.2-2.fc8 has fixed things.

Thanks for confirming! I will request to push 0.6.2-2.fc8.
Also reported to upstream:
http://rubyforge.org/tracker/index.php?func=detail&aid=16728&group_id=205&atid=863
Comment 5 Mamoru TASAKA 2007-12-31 09:04:35 EST
By the way, are you using evolution as mail client?
If so, would you tell me the NVR (name-version-release) of
evolution. evolution-data-server for information?
Comment 6 James Begley 2007-12-31 09:16:40 EST
Yes, I'm using evolution as my mail client.

[james@jumbovaio ~]$ rpm -qa | grep evolution
evolution-exchange-2.12.2-2.fc8
ruby-revolution-0.5-1.svn210.fc8
evolution-webcal-2.12.0-1.fc8
evolution-sharp-0.14.0.1-1.fc8
mail-notification-evolution-plugin-4.1-4.1
evolution-data-server-devel-1.12.2-1.fc8
evolution-data-server-1.12.2-1.fc8
evolution-2.12.2-2.fc8
Comment 7 Fedora Update System 2008-01-02 20:29:43 EST
alexandria-0.6.2-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-01-02 20:30:12 EST
alexandria-0.6.2-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.