Bug 427071 - OOo Calc crashed, spell checking related?
OOo Calc crashed, spell checking related?
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-30 16:55 EST by André Johansen
Modified: 2008-01-22 10:41 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.0-6.11.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:41:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash report output (9.97 KB, text/plain)
2007-12-30 16:55 EST, André Johansen
no flags Details
mapped stack (5.92 KB, text/plain)
2008-01-02 05:02 EST, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 81314 None None None Never

  None (edit)
Description André Johansen 2007-12-30 16:55:36 EST
Description of problem:
Was editing a simple spreadsheet when the Calc application suddenly crashes 
when idle.

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.3.0-6.7.fc8.x86_64

How reproducible:
Unknown.

Steps to Reproduce:
  
Actual results:
OpenOffice crashed.  The crash report is attached (from ~/.xsession-errors).

Expected results:


Additional info:
Comment 1 André Johansen 2007-12-30 16:55:36 EST
Created attachment 290560 [details]
Crash report output
Comment 2 Caolan McNamara 2008-01-02 05:02:38 EST
Created attachment 290639 [details]
mapped stack
Comment 3 Caolan McNamara 2008-01-02 05:50:09 EST
Hmm, indeed it does seem like some spellchecking related crash, but I can't see
why. Perhaps this is restricted to some particular locale or language. What's
your default language, i.e. the output of $LANG ?
Comment 4 Caolan McNamara 2008-01-02 05:57:39 EST
This *might* be the same as http://www.openoffice.org/issues/show_bug.cgi?id=81314
Comment 5 André Johansen 2008-01-02 06:11:37 EST
LANG is en_GB.UTF-8

In case it is of value, the spreadsheet was made by copying text from a 
Microsoft Word document; the text was in Norwegian (Norsk bokmål), and had 
several spelling mistakes.
Comment 6 Caolan McNamara 2008-01-02 06:17:28 EST
If you are allowed to, then attach the spreadsheet, I'd be very interested in
seeing if I can reproduce it to verify that it is the above upstream issue
Comment 7 André Johansen 2008-01-02 06:32:58 EST
Probably not allowed, as it contained economical information.
I was unable to reproduce it myself, though.  But then again, I don't know 
what the real trigger is/was, so might have been lucky second time around.
(If I get to reproduce it, I'll add more information.)
Comment 8 Caolan McNamara 2008-01-03 14:51:50 EST
I'll assume that it is http://www.openoffice.org/issues/show_bug.cgi?id=81314 
in which case the fix will be in >= 2.3.0-6.10 which will be released for F-8
eventually
Comment 9 Fedora Update System 2008-01-06 20:19:04 EST
openoffice.org-2.3.0-6.10.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'
Comment 10 Fedora Update System 2008-01-15 18:06:29 EST
openoffice.org-2.3.0-6.11.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'
Comment 11 Fedora Update System 2008-01-22 10:41:51 EST
openoffice.org-2.3.0-6.11.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.