Bug 427090 - Complete german translation
Complete german translation
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 479644
  Show dependency treegraph
 
Reported: 2007-12-31 06:55 EST by Fabian Affolter
Modified: 2009-09-21 17:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-29 19:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
de.po (19.23 KB, text/x-gettext-translation)
2007-12-31 06:55 EST, Fabian Affolter
no flags Details
fixed version of German po file (19.28 KB, text/x-gettext-translation)
2008-02-18 18:08 EST, Fabian Affolter
no flags Details
patch from the de.po in the 0.6.22 release to Fabian Affolter's version (15.78 KB, patch)
2008-03-03 02:06 EST, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Fabian Affolter 2007-12-31 06:55:00 EST
Initial version of the complete german translation
Comment 1 Fabian Affolter 2007-12-31 06:55:00 EST
Created attachment 290573 [details]
de.po
Comment 2 Fabian Affolter 2008-01-10 13:27:56 EST
Can you please upload it to your repository? Thanks
Comment 3 Kevin Kofler 2008-02-15 07:37:37 EST
Some corrections (in the stuff which was added/changed compared to the 0.6.22 
tarball):
* "Ungültig RDATA" should be "Ungültige RDATA"
* "Druchsuchen nach Dienst-Typen %s in Domain %s fehlgeschlagen: %s" should 
be "Durchsuchen nach Dienst-Typen %s in Domain %s fehlgeschlagen: %s" (typo)
* "Durchsuche nach suchenden Domäne" sounds ungrammatical to me, not sure how 
to fix it though
* "Aktiviert detailierten Modus" (appears 3 times in the file) should 
be "Aktiviert detaillierten Modus" (double "l")
* "Namenskollosion, wähle neuen Name '%s'.\n" should be "Namenskollision, wähle 
neuen Name '%s'.\n" (typo)
* "Domain zum Veröffentlichen des Dienstes auf" and "Ein zusätzlicher Untertyp 
zum Registrieren des Dienstes mit" are very ungrammatical, also "domain" is 
translated as "Domäne" everywhere else
* "Parsern der Port-Nummer fehlgeschlagen: %s\n" should probably be "Parsen der 
Port-Nummer fehlgeschlagen: %s\n"

I'd also suggest translating "domain browser" as "Domänenbrowser" rather 
than "Domäne-Browser".

I can add the translation update as a patch to the rawhide package (unless they 
remove cvsextras access when unorphaning it), but I'd like these issues 
adressed first.
Comment 4 Kevin Kofler 2008-02-15 07:51:09 EST
> * "Druchsuchen nach Dienst-Typen %s in Domain %s fehlgeschlagen: %s" should 
> be "Durchsuchen nach Dienst-Typen %s in Domain %s fehlgeschlagen: %s" (typo)

Actually it should also say "Domäne" rather than "Domain" (or all the messages 
saying "Domäne" should be changed to say "Domain", but it should be 
consistent).
Comment 5 Fabian Affolter 2008-02-18 18:08:15 EST
Created attachment 295219 [details]
fixed version of German po file
Comment 6 Kevin Kofler 2008-03-03 02:06:28 EST
Created attachment 296559 [details]
patch from the de.po in the 0.6.22 release to Fabian Affolter's version

Here's a patch. Lennart, can you please commit this to the upstream tree? This
translation comes from one of Fedora's official translators, and it has been
proofread (by me), so I really don't see a good reason not to update the
translation right now. I'm going to commit this to the Fedora package in the
meantime because I'm fed up of waiting (and Fabian has been in that state for a
while, judging from his blog post).
Comment 7 Kevin Kofler 2008-03-03 02:12:36 EST
By the way, you're supposed to use %find_lang to package translations, not 
list %{_datadir}/locale/*. See 
http://fedoraproject.org/wiki/Packaging/Guidelines#head-8c605ebf8330f6d505f384e671986fa99a8f72ee
Comment 8 Kevin Kofler 2008-03-19 18:20:03 EDT
FYI, this is now committed in Rawhide, but I'm keeping this open because it 
really ought to be updated upstream too and Lennart is the upstream maintainer.
Comment 9 Fabian Affolter 2008-03-19 18:29:38 EDT
Filled http://avahi.org/ticket/202 to bring it upstream.
Comment 10 Piotr Drąg 2008-03-19 18:38:55 EDT
Lennart as the upstream maintainer is not very active. Last commit in po/
directory was 3 months ago, and tickets about translations never got any answer:

http://avahi.org/ticket/202
http://avahi.org/ticket/189
http://avahi.org/ticket/203
http://avahi.org/ticket/200
Comment 11 Fabian Affolter 2008-03-19 18:49:34 EDT
In order to remain fair...#202 and #203 are brand new entries (2008-03-19)
Comment 12 Piotr Drąg 2008-03-19 18:55:24 EDT
Right, I've noticed it just after sending this comment...
Comment 13 Kevin Kofler 2008-03-19 19:11:46 EDT
This bug has been open since Dec 31 though.

Sadly, the best way to get those translations into Fedora appears to be to get 
somebody with cvsextras access to patch them in, and that won't help users of 
other distributions. :-( This problem is only going to get worse as more 
translations become available.

Lennart, where are you???
Comment 14 Lennart Poettering 2008-03-26 17:09:59 EDT
I am here, just not so keen on constantly merging in translations. I am kind of
waiting that Dimitri adds non-SSH-based SVN support to Transifex. As soon as
that is done I don't have to deal with them anymore.
Comment 15 Ted Percival 2008-03-27 07:18:18 EDT
This has been committed upstream in revision 1759.

You can ping me to commit future updates, if you like.
Comment 16 Kevin Kofler 2008-03-27 07:23:05 EDT
What about Piotr Drąg's Polish translation (http://avahi.org/ticket/189)?
Comment 17 Ted Percival 2008-03-27 08:10:46 EDT
I'll do it soon. Just as soon as I can figure out how intltool works and
actually test these ;)
Comment 18 Ted Percival 2008-03-27 10:07:27 EDT
Does the Fedora package's translation work as-is? I needed to add
  ALL_LINGUAS="de"
to configure.ac (and then run autoconf) as well as installing the
/usr/share/locale/de/LC_MESSAGES/avahi.mo file (which I can't see in the
avahi.spec file in Fedora's 0.6.22-9 SRPM).

I'll sit down and ensure that the translations work when I get a chance --
probably not for a few days though.
Comment 19 Kevin Kofler 2008-03-27 10:11:54 EDT
The specfile packages %{_datadir}/locale/* (which is a blatant wildcard abuse, 
that's what find_lang is for! But it sorta works).
Comment 20 Ted Percival 2008-03-29 09:55:31 EDT
The German and Polish translations have been committed, as well as the changes
to the desktop files so they can be translated. This covers upstream ticket
numbers 189, 200 and 202.

I don't have permission to change this bug's state.

Note You need to log in before you can comment on or make changes to this bug.