Bug 427115 - SIMPLE (w/ patch) MOZ_ARCH should be settable. (i want 32-bit firefox even on 64bit installs)
SIMPLE (w/ patch) MOZ_ARCH should be settable. (i want 32-bit firefox even o...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-31 18:05 EST by Stig Hackvan
Modified: 2007-12-31 22:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 22:57:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2007-12-31 18:05:44 EST
Description of problem:

some 3rd party plugins for firefox (flash) ship in 32-bit versions.  Ergo, i
want to be able to tell firefox to run in 32bit mode...but the startup script
makes this really tough.  i keep having to hack /usr/bin/firefox.

ideally, the firefox startup script would respect the MOZ_ARCH variable instead
of clobberring it....and ideally 3rd-party plugins (flash) would install export
MOZ_ARCH=i386 into /etc/profile.d and the world would be grand...

please incorporate this patch...


PATCH:

--- firefox~    2007-12-13 08:21:51.000000000 -0800
+++ firefox     2007-12-28 21:47:11.000000000 -0800
@@ -36,7 +36,7 @@
 ##
 ## Variables
 ##
-MOZ_ARCH=$(uname -m)
+[ "$MOZ_ARCH" ] || MOZ_ARCH=$(uname -m)
 case $MOZ_ARCH in
        x86_64 | ia64 | s390 )
                MOZ_LIB_DIR="/usr/lib64"
Comment 1 Christopher Aillon 2007-12-31 22:57:08 EST
From the shell:

setarch i386

(or whatever you want)
Comment 2 Christopher Aillon 2007-12-31 22:58:28 EST
But fwiw, flash works for me using the 64bit firefox.  Make sure you have
nspluginwrapper.i386 and nspluginwrapper.x86_64 installed.  Firefox is much
faster in this mode.

Note You need to log in before you can comment on or make changes to this bug.