Bug 427117 - idle direct mounts unmounted by HUP to automount
idle direct mounts unmounted by HUP to automount
Status: CLOSED DUPLICATE of bug 336961
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-31 18:14 EST by Deke Clinger
Modified: 2008-01-04 00:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 00:45:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
automount debug output from autofs-5.0.1-0.rc2.79 (2.73 MB, text/plain)
2008-01-03 20:46 EST, Deke Clinger
no flags Details

  None (edit)
Description Deke Clinger 2007-12-31 18:14:13 EST
Description of problem:

sending a HUP signal to the automount process unmounts all the idle direct mounts. 

Version-Release number of selected component (if applicable):

kernel 2.6.18-53.1.4.el5 and autofs-5.0.1-0.rc2.55

How reproducible:
every time

Steps to Reproduce:
1. start automount with a large (6500 entry) direct map & debug logging
2. send a HUP signal to the automount pid
3. watch syslog, observe falling count of direct map entries
  
Actual results:

direct mounts are removed

Expected results:

daemon rereads config files, picks up any new entries

Additional info:

I've been discussing this with Ian Kent already - he believes it's already fixed
in the version in CVS.
Comment 1 Ian Kent 2007-12-31 22:30:21 EST
(In reply to comment #0)
> I've been discussing this with Ian Kent already - he believes it's already fixed
> in the version in CVS.

I've uploaded the current i386 and x86_64 CVS builds to
http://www.eu.kernel.org/pub/linux/kernel/people/raven/autofs.
If you need different archs let me know.

As always we must keep in mind that these are the current CVS
development and haven't completed the QA process so there may
be unexpected problems. But then that's what testing is about.

Your help is appreciated.
Ian
Comment 2 Ian Kent 2008-01-01 07:11:08 EST
(In reply to comment #1)
> I've uploaded the current i386 and x86_64 CVS builds to
> http://www.eu.kernel.org/pub/linux/kernel/people/raven/autofs.
> If you need different archs let me know.

That should read www.kernel.org not www.eu.kernel.org.

Ian
Comment 3 Deke Clinger 2008-01-03 20:46:18 EST
Created attachment 290809 [details]
automount debug output from autofs-5.0.1-0.rc2.79
Comment 4 Deke Clinger 2008-01-03 20:49:52 EST
I've downloaded autofs-5.0.1-0.rc2.79 and installed it on a test host. I'm still
seeing the same problem, but the debug output is a lot more verbose now. I'm
attaching the log to this bug. 

Thanks,

-Deke
Comment 5 Ian Kent 2008-01-03 21:56:06 EST
(In reply to comment #4)
> I've downloaded autofs-5.0.1-0.rc2.79 and installed it on a test host. I'm still
> seeing the same problem, but the debug output is a lot more verbose now. I'm
> attaching the log to this bug. 

Thanks for the log.
Looks like I've been able to duplicate the problem.
I'll dig a bit deeper.

Ian
Comment 6 Ian Kent 2008-01-04 00:45:38 EST
*Sigh*, the included map stuff is a bit tricky.

I'm going to mark this bug as a duplicate of bug 336961 because
the symptoms are the same and it looks like a case that was
missed in the correction for that bug.

Ian


*** This bug has been marked as a duplicate of 336961 ***

Note You need to log in before you can comment on or make changes to this bug.