Bug 427142 - firefox crashes during load of the page
firefox crashes during load of the page
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
http://www.postbank.de
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 05:31 EST by agr
Modified: 2008-01-22 19:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 19:04:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description agr 2008-01-01 05:31:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc7 Firefox/2.0.0.10

Description of problem:
During load of the page above the browser is closed.
Opening the page is only possible with deactivated javascript.

The error console reports the message below:

Fehler: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPrefBranch.getComplexValue]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/lib/firefox-2.0.0.10/components/nsBrowserContentHandler.js :: anonymous :: line 517"  data: no]
Quelldatei: file:///usr/lib/firefox-2.0.0.10/components/nsBrowserContentHandler.js
Zeile: 499

Version-Release number of selected component (if applicable):
firefox-2.0.0.10-2.fc7

How reproducible:
Always


Steps to Reproduce:
1. open the web page http://www.postbank.de
2.
3.

Actual Results:
The whole browser window is silently closed, firefox is closed.

Expected Results:
Presentation of the page, as in other browsers.

Additional info:
Comment 1 Jian He 2008-01-05 03:38:10 EST
my firefox version is firefox-2.0.0.10-2.fc7
open http://www.postbank.de will not crashes.
but open http://lkml.org/lkml/2006/6/28/107 will crashes.
Comment 2 Matěj Cepl 2008-01-06 20:05:11 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please install firefox-debuginfo; in order to do this you have to enable
-debuginfo repository.

	yum install --enablerepo=\*debuginfo firefox-debuginfo

(if you use x86_64 firefox, install firefox-debuginfo.x86_64  package).

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Jian He 2008-01-06 21:37:29 EST
Thanks for the detail instructions.

In my x86_64 F7 box, I am running a firefox.i386 2.0.0.10-2.fc7, but "yum
install --enablerepo=\*debuginfo firefox-debuginfo" will install the
firefox-debuginfo.x86_64 0:3.0-0.beta2.7.fc9? there has no
firefox-debuginfo.i386 version.

And when I running "firefox -g" and open "http://lkml.org/lkml/2006/6/28/107" it
suddenly crashed, and could not go back to the gdb, I only got this:
$ firefox -g
Segmentation fault
$

But if I running a firefox.x86_64 version instead of the firefox.i386, it will
not broken and it works fine.

Thanks again.
Comment 4 agr 2008-01-19 06:50:07 EST
Hi,
after installation of firefox-debuginfo there was no gdb - output during the
firefox - call - see below:
++++++++++++++++++++++++++++++++++++++
[a ~]$ rpm -qa |grep firefox-debuginfo
firefox-debuginfo-3.0-0.beta2.8.fc9
[a ~]$ firefox -g
Segmentation fault
[a ~]$
++++++++++++++++++++++++++++++++++++++
gdb itself is installes and can be started
Comment 5 Christopher Aillon 2008-01-22 15:01:08 EST
Doesn't crash using latest rawhide.

% rpm -q firefox xulrunner
firefox-3.0-0.beta2.12.nightly20080121.fc9.x86_64
xulrunner-1.9-0.beta2.12.nightly20080121.fc9.x86_64
Comment 6 Matěj Cepl 2008-01-22 19:04:45 EST
Cannot reproduce with firefox-2.0.0.10-3.fc8 on Fedora 8 either. Closing as
WORKSFORME, because we really cannot do much about the bug which we cannot
reproduce.

If anybody is able to reproduce this bug with the latest updates of their
current distro and who are able to create useful backtrace, please, reopen this
bug and attach additional information on how to reproduce it.

Note You need to log in before you can comment on or make changes to this bug.