Bug 427156 - lots of permission probs from an old home dir on second drive
lots of permission probs from an old home dir on second drive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: GConf (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 11:01 EST by Jonah
Modified: 2008-01-03 11:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 10:45:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of rpm command i was given (606.95 KB, text/plain)
2008-01-03 11:30 EST, Jonah
no flags Details

  None (edit)
Description Jonah 2008-01-01 11:01:19 EST
Description of problem:
Hi I copied my old home dir from ubuntu to a second drive then installed fedora,
then dragged what i needed back. but i always get errors now, it's as if fedora
installed and detected something in the old home dir.

on boot up i get this problem:

Starting sendmail: 451 4.0.0 /etc/mail/sendmail.cf: line 91: fileclass: cannot
open 'etc/mail/local-host-names': world writeable directory.

i also get two similar errors under that section with /etc/mail/trusted-users.

then when x starts etc, i get this error:

User's $Home/.drmc file is being ignored. This prevents default session. File
should be owned by user and have 644 permissions. User $Home directory should be
owned by user and not writeable by others.

it all seems to be permission probs that started from backing up my old home dir
from ubuntu.

can anyone please help me fix this. thanks.
Comment 1 Ray Strode [halfline] 2008-01-02 10:45:35 EST
the forums or IRC would be a better place to get help fixing these issues.

chown $(id -un).$(id.gn) ~ -R
chmod 644 ~/.dmrc

(as the user)

find /etc -exec chmod o-w {} \;

(as root)

may fix things somewhat.

rpm -qVa

should give a list of other problems.
Comment 2 Jonah 2008-01-02 17:54:58 EST
hi thanks for helping me out, i came to bugzilla from desperation as i've tried
many times on irc and no one seems to be able to help me. i figured this was a
kind of bug as all i did was install with an old home dir on another drive, this
shouldn't have conflicted anything really...

i inputted what you said:

[jonah@localhost ~]$ chown $(id -un).$(id.gn) ~ -R
bash: id.gn: command not found

as for the rpm -qVa bit, there are so many things scrolling past that they don't
fit in my terminal history so i can't paste it in...
Comment 3 Ray Strode [halfline] 2008-01-03 10:40:38 EST
i'm sorry, when I typed id.gn i meant to type id -gn

you can redirect the output of rpm -qVa to a file with >, for example,

rpm -qVa > verify.log
Comment 4 Jonah 2008-01-03 11:30:32 EST
Created attachment 290740 [details]
output of rpm command i was given

hi here is the log file you needed.

Note You need to log in before you can comment on or make changes to this bug.