This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 427167 - Lack of symlink
Lack of symlink
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 14:26 EST by Patrice Le Gurun
Modified: 2008-08-16 07:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-16 07:10:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Le Gurun 2008-01-01 14:26:24 EST
Description of problem:
It's seems there is a lack of a symlink to /usr/share/mediawiki/skins/ directory
in /var/www/wiki/.

Version-Release number of selected component (if applicable):
1.9.4-35.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install mediawiki via yum
2. Configure it
  
Actual results:
After configuration, web pages should respect mediawiki themes.

Expected results:
After configuration, web pages don't respect mediawiki themes (no images and no
CSS, so the display is ugly).

Additional info:
It seems there is a lack of symlink to /usr/share/mediawiki/skins/ directory in
/var/www/wiki/. Adding this symlink solve the problem.
Maybe others symlinks are required, but with the skins symlink all seems to be ok.
Comment 1 Axel Thimm 2008-08-16 07:10:58 EDT
You don't need to (and shouldn't) symlink anything more to the web exposed mediawiki install, just use

    Alias /skins     /usr/share/mediawiki/skins

in your httpd.conf where appropriate.

Note You need to log in before you can comment on or make changes to this bug.