Bug 427178 - fake .svn directories breaking po file creation
fake .svn directories breaking po file creation
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Michael Hideo
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 19:35 EST by Jeff Fearn
Modified: 2010-11-23 22:59 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-01 19:57:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2008-01-01 19:35:55 EST
Description of problem:


Version-Release number of selected component (if applicable):
When you run update-po-all to create the po files fake .svn directories are
being created which prevent svn add from working.

How reproducible:
Always

Steps to Reproduce:
1. svn co a book with no translations
2. cd book
3. ensure OTHER_LANGS contains at least one language
4. make update-po-all
5. svn add <some lang>

Actual results:
Error stating that <some lang> is already under version control.

Expected results:
svn add should work.

Additional info:
This is due to EXTRA_DIRS not excluding .svn directory.
Comment 1 Jeff Fearn 2008-01-01 19:57:21 EST
Updated EXTRA_DIRS to exclude .svn directories.

Added svn_add_po make target to aid adding po files to svn repo.

Note You need to log in before you can comment on or make changes to this bug.