Bug 42718 - mga450 hangs at startup
Summary: mga450 hangs at startup
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-29 17:05 UTC by Enrico Scholz
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 13:21:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/XF86Config-4 (2.29 KB, patch)
2001-05-29 17:06 UTC, Enrico Scholz
no flags Details | Diff
X11 output (4.75 KB, text/plain)
2001-06-01 00:43 UTC, Enrico Scholz
no flags Details

Description Enrico Scholz 2001-05-29 17:05:11 UTC
Description of Problem:

X (from -4.0.99) hangs on my system on startup. Last output was


| (II) Module i2c: vendor="The XFree86 Project"
|        compiled for 4.0.99.900, module version = 1.2.0

With XFree86-4.0.3 a warning follows, but then all things are fine:

| (II) Module i2c: vendor="The XFree86 Project"
|         compiled for 4.0.3, module version = 1.2.0
| (WW) MGA(0): Failed to set up write-combining range
(0xe2000000,0x1800000)
| (II) MGA(0): I2C bus "DDC" initialized.


gdb shows that X loops between 0x8098362 and 0x8098371 (sorry, I have not
compiled debug-symbols into):

-------------
0x8098359:      lea    0x0(%edi,1),%edi
0x8098360:      sar    %ebx
0x8098362:      cmp    %esi,%ebx
0x8098364:      jg     0x8098360
0x8098366:      mov    %edi,%eax
0x8098368:      cltd   
0x8098369:      idiv   %ebx,%eax
0x809836b:      test   %edx,%edx
0x809836d:      je     0x80983c0
0x809836f:      test   %ebx,%ebx
0x8098371:      jne    0x8098362
0x8098373:      test   %ebx,%ebx
0x8098375:      jne    0x809838d
0x8098377:      sub    $0x4,%esp

(gdb) info reg
eax            0x0      0
ecx            0xffffffff       -1
edx            0xe2000000       -503316480
ebx            0x80000000       -2147483648
esp            0xbffff6f0       0xbffff6f0
ebp            0xbffff708       0xbffff708
esi            0x1800000        25165824
edi            0xe2000000       -503316480
eip            0x809836b        0x809836b
--------------

/var/log/messages says

--------------
May 29 18:40:59 kosh kernel: Linux agpgart interface v0.99 (c) Jeff
Hartmann 
May 29 18:40:59 kosh kernel: agpgart: Maximum main memory to use for agp
memory: 203M 
May 29 18:40:59 kosh kernel: agpgart: Detected Intel 440BX chipset 
May 29 18:40:59 kosh kernel: agpgart: AGP aperture is 64M @ 0xe4000000 
May 29 18:41:01 kosh kernel: [drm] AGP 0.99 on Intel 440BX @ 0xe4000000
64MB 
May 29 18:41:01 kosh kernel: [drm] Initialized mga 2.0.1 20000928 on minor
63 
...
ay 29 18:47:35 kosh kernel: mtrr: base(0xe2000000) is not aligned on a
size(0x1800000) boundary 
May 29 18:47:36 kosh kernel: mtrr: no MTRR for e3800000,800000 found 
May 29 18:47:36 kosh kernel: mtrr: base(0xe2000000) is not aligned on a
size(0x1800000) boundary 
May 29 18:47:57 kosh kernel: mtrr: base(0xe2000000) is not aligned on a
size(0x1800000) boundary
-----------------

How Reproducible:

everytime

Steps to Reproduce:
1. X

Actual Results:

hangup


Expected Results:

gray screen


Additional Information:
	
$ lspci -v
...
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev
03) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: e0000000-e0ffffff
        Prefetchable memory behind bridge: e1f00000-e3ffffff
00:0a.0 Multimedia video controller: Brooktree Corporation Bt848 TV with
DMA push (rev 12)
        Flags:bus master, medium devsel, latency 32, IRQ 3
        Memory at e1000000 (32-bit, prefetchable) [size=4K]
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev
82) (prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc.: Unknown device 0641
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at e2000000 (32-bit, prefetchable) [size=32M]
        Memory at e0800000 (32-bit, non-prefetchable) [size=16K]
        Memory at e0000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at e1fe0000 [disabled] [size=128K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0
...

$ cat /proc/mtrr
reg00: base=0x00000000 (   0MB), size= 256MB: write-back, count=1
reg01: base=0xe4000000 (3648MB), size=  64MB: write-combining, count=1
reg05: base=0xe2000000 (3616MB), size=  32MB: write-combining, count=3


tested with XFree86-4.0.99.900-0.2.[13].i386.rpm; XFree86-4.0.3-15 works
fine
kernel is the original 2.4.5 one

XF86Config will be attached

Comment 1 Enrico Scholz 2001-05-29 17:06:26 UTC
Created attachment 19892 [details]
/etc/X11/XF86Config-4

Comment 2 Mike A. Harris 2001-05-31 23:27:29 UTC
Arjan, do these kernel messages indicate a kernel bug, or indicate a bug
in X when trying to configure MTRR's?

Or is this possibly caused because the DRM modules are from 4.0.3, but
he's using 4.0.99.x?

Comment 3 Enrico Scholz 2001-06-01 00:42:59 UTC
The drm module is this shipped with 4.0.99. I will attach the complete output of
X...

Comment 4 Enrico Scholz 2001-06-01 00:43:47 UTC
Created attachment 20051 [details]
X11 output

Comment 5 Mike A. Harris 2001-06-01 02:28:13 UTC
DRM is kernel modules.  They do not ship with our XFree86.  You're using
XFree86 4.0.99.x with kernel 2.4.x's kernel modules (From seawolf?)
DRM has not yet been integrated into our kernel in rawhide, so DRI will not
work at all with rawhide.  The XFree86 side of DRI is ok, but the kernel side
is not ok.

Comment 6 Arjan van de Ven 2001-06-01 09:06:26 UTC
MTRR warnings are usually a bios bug; except on athlons where the 2.4.2-2 kernel
had a slight bug that is fixed in 2.4.3-X kernels


Comment 7 Enrico Scholz 2001-06-01 13:17:55 UTC
> You're using  XFree86 4.0.99.x 

yes

> with kernel 2.4.x's kernel modules (From seawolf?)

no; I am using the official 2.4.[45] kernel (from ftp.kernel.org)

Comment 8 Enrico Scholz 2001-06-05 18:24:22 UTC
seems to be fixed in XFree86-4.1.0-0.0.1


Note You need to log in before you can comment on or make changes to this bug.