Bug 427182 - firefox3 not localized
firefox3 not localized
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
: Reopened
: 437431 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-01-01 22:31 EST by Jens Petersen
Modified: 2013-01-09 23:32 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-08 22:51:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-01-01 22:31:25 EST
Description of problem:
If one runs firefox in a locale with a langpack like Japanese,
the chrome appears in English.

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta2.4.fc9

How reproducible:
every time

Steps to Reproduce:
1. start desktop in Japanese (or Japanese system locale)
2. start firefox
  
Actual results:
2. firefox appears with English menus etc

Expected results:
2. Japanese chrome
Comment 1 Parag Nemade 2008-01-02 04:27:28 EST
I saw that current firefox.spec got changed according to new firefox 3 tarball
but langpack tarball is still same as of firefox-2.0.0.10.

If you look at install.pdf from ja.xpi, its clearly seen as its 
               em:version="2.0.0.10"
and not
               em:version="3.0b3pre"

So, we need to replace langpacks with new upstream translations available at
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk-l10n/linux-xpi/
Comment 2 Parag Nemade 2008-01-02 06:11:17 EST
s/install.pdf/install.rdf
Comment 3 Martin Stransky 2008-01-02 07:04:47 EST
taking the bug
Comment 4 Martin Stransky 2008-01-02 08:09:39 EST
Should be fixed in firefox-3.0-0.beta2.5.fc9.
Comment 5 A S Alam 2008-01-25 02:02:21 EST
still no firefox lang pack for any langauge in following build:
firefox-3.0-0.beta2.12.nightly20080121.fc9
Comment 6 Martin Stransky 2008-01-25 04:55:42 EST
Langpacks are disabled for now.
Comment 7 Thomas Canniot 2008-03-30 04:20:35 EDT
Will they be enabled for Fedora 9 release ?
Comment 8 Johan Cwiklinski 2008-03-30 04:31:27 EDT
(In reply to comment #6)
> Langpacks are disabled for now.

Why ?
Comment 9 Christopher Aillon 2008-03-31 10:30:14 EDT
Because they were incomplete.  In Mozilla land, incomplete langpacks means the
browser may not start or will have functionality missing.  Too many complaints
were filed that the browser was useless with them enabled at one point, so they
were removed.

Stealing this one from you, Martin...  I'll be adding these back soon.
Comment 10 Christopher Aillon 2008-03-31 10:45:14 EDT
*** Bug 437431 has been marked as a duplicate of this bug. ***
Comment 11 Jesse Keating 2008-04-07 10:10:37 EDT
Hey Chris, just need to get a reasonable estimate if the langpacks can be
re-enabled for F9 Gold (freeze is late tonight).  If not, we'll remove this from
the blocker, but if so I'd like to leave it on the blocker list for tracking.
Comment 12 Jesse Keating 2008-04-08 22:51:38 EDT
Looks like langpacks got added back in.  Closing rawhide.
Comment 13 Jens Petersen 2008-04-10 00:13:12 EDT
Thank you

Note You need to log in before you can comment on or make changes to this bug.