Bug 427185 - Review Request: okteta - Binary editor
Review Request: okteta - Binary editor
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-01 23:06 EST by Kevin Kofler
Modified: 2008-01-21 04:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 00:56:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michel: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Kevin Kofler 2008-01-01 23:06:50 EST
Spec URL: http://repo.calcforge.org/f9/okteta.spec
SRPM URL: http://repo.calcforge.org/f9/okteta-0.0.1-0.1.20080102svn755662.fc8.src.rpm
Description:
This is the replacement for khexedit, which has been dropped from kdeutils for
the KDE 4.0 release. The RPM %description follows:
Okteta allows the user to load data from any file, view and edit it in
either hex or ASCII. Okteta uses the KDE 4 libraries.

I tested the package on F8 i386 and it starts up fine and loads all the files
I tried correctly.

Packaging note: I am not packaging the oktetapart because it conflicts with
the version in kdeutils (kdeutils 4.0 only contains the KPart, not the full
application, which is scheduled to be merged in 4.1) and because the
application doesn't actually use the KPart, only the common libraries.
Comment 1 Kevin Kofler 2008-01-08 18:35:35 EST
Hmmm, it looks like kdeutils-4.0.0 contains some oktetapart sources, but the 
directory is missing a CMakeLists.txt and thus not actually being built.

I guess I'll just reenable the oktetapart in this package, it's newer anyway.
Comment 2 Michel Alexandre Salim 2008-01-13 21:11:29 EST
Could you list the requirements for testing this on F8? I've only seen KDE4
packages for Rawhide so far, and when I tried installing kdebase from Rawhide
it's pulling too many updates that I don't feel comfortable installing on my
main machine.
Comment 3 Kevin Kofler 2008-01-13 21:16:55 EST
Build-time: kdelibs4-devel
Run-time: kdelibs4, kdebase-runtime
(It may sort-of run without kdebase-runtime, but it'll definitely be missing 
icons and such, so installing kdebase-runtime is recommended.)
These can be found in F8 updates (currently the old 3.96.2 version) or 
updates-testing (4.0.0).
Comment 4 Michel Alexandre Salim 2008-01-13 22:05:07 EST
rpmlint complains about library files that are not ldconfig-ed, though it does
not seem to affect the package's running.

$ rpmlint ../RPMS/okteta-0.0.1-0.1.20080102svn755662.fc8.x86_64.rpm 
okteta.x86_64: W: no-documentation
okteta.x86_64: E: library-without-ldconfig-postin
/usr/lib64/liboktetacore_b.so.4.0.0
okteta.x86_64: E: library-without-ldconfig-postun
/usr/lib64/liboktetacore_b.so.4.0.0
okteta.x86_64: E: library-without-ldconfig-postin /usr/lib64/liboktetagui_b.so.4.0.0
okteta.x86_64: E: library-without-ldconfig-postun /usr/lib64/liboktetagui_b.so.4.0.0
Comment 5 Kevin Kofler 2008-01-13 22:12:16 EST
Oops, good catch.
Comment 6 Kevin Kofler 2008-01-13 22:46:49 EST
Note that it would be nice to test this with package_kpart set back to 1 as 
this will probably be how it'll end up when actually imported (see comment #1). 
(I can respin a new SRPM if needed.)
Comment 7 Kevin Kofler 2008-01-15 02:12:57 EST
Updated:
Spec URL: http://repo.calcforge.org/f9/okteta.spec
SRPM URL: 
http://repo.calcforge.org/f9/okteta-0.0.1-0.1.20080115svn761510.fc8.src.rpm

- Update to revision 761510
- Enable package_kpart
- Add missing ldconfig scriptlets for the shared libraries

The only rpmlint complaint left is the no-documentation one which is basically 
upstream's fault for not including a COPYING file.
Comment 8 Michel Alexandre Salim 2008-01-15 12:27:55 EST
Almost done -- one question about desktop-file-utils, and another about macros.
Also, on a system without KDE4 installed, the application menu does not show any
icon (khexedit icon is not on the system), and the application itself does not
have any icons (presumably because oxygen theme is not installed).

MUST

Passed:
• rpmlint
• package name
• spec file name
• package guideline-compliant
• license complies with guidelines
• license field accurate
• license file not deleted
• spec in US English
• spec legible
• source matches upstream
• builds under >= 1 archs, others excluded
• build dependencies complete
• locales handled using %find_lang, no %{_datadir}/locale
• library -> ldconfig
• own all directories
• no dupes in %files
• permission
• %clean RPM_BUILD_ROOT
• Package contains code
• clean buildroot before install
• filenames UTF-8

N/A:
• large docs => -doc
• doc not runtime dependent
• headers in -devel
• static in -static
• if contains *.pc, req pkgconfig
• if libfiles are suffixed, the non-suffixed goes to devel
• devel requires versioned base package

Unknown:
• macros used consistently
Question: are those _kde4_* macros going to be present for the foreseeable future?

FAILED:
• desktop file uses desktop-file-install

Comment 9 Kevin Kofler 2008-01-15 12:35:49 EST
The _kde4_* macros will be present forever, they allow us to define e.g. 
_kde4_includedir to %{_includedir}/kde4.

For desktop-file-install, unfortunately KDE has always had its own ways of 
installing .desktop files, we'd have to reinstall the already installed 
one. :-( It will also lead to the .desktop file landing in a different place as 
upstream (they use kde4/*.desktop rather than kde4-*.desktop as you get with 
desktop-file-install --vendor).
Comment 10 Kevin Kofler 2008-01-15 12:52:51 EST
Actually it turns out it's easy to run desktop-file-install on the 
installed .desktop file to validate it (thanks to Rex Dieter for clearing that 
up). This does the trick:
desktop-file-install %{buildroot}%{_datadir}/applications/kde4/okteta.desktop --vendor "" --dir %{buildroot}%{_datadir}/applications/kde4
So I'm fixing this.
Comment 11 Kevin Kofler 2008-01-15 13:25:43 EST
Updated:
Spec URL: http://repo.calcforge.org/f9/okteta.spec
SRPM URL: 
http://repo.calcforge.org/f9/okteta-0.0.1-0.2.20080115svn761510.fc8.src.rpm

- Use desktop-file-install to ensure the .desktop file is valid
Comment 12 Michel Alexandre Salim 2008-01-15 22:53:10 EST
Changes look fine - APPROVED
Comment 13 Kevin Kofler 2008-01-16 02:38:04 EST
New Package CVS Request
=======================
Package Name: okteta
Short Description: Binary editor
Owners: kkofler,than,rdieter,ltinkl
Branches:
InitialCC:
Cvsextras Commits: no
Comment 14 Kevin Fenzi 2008-01-16 12:37:15 EST
cvs done.
Comment 15 Michel Alexandre Salim 2008-01-21 00:56:57 EST
This is meant for F9 and above only, presumably? In which case I am closing the
bug entry -- package has hit Rawhide.
Comment 16 Kevin Kofler 2008-01-21 04:10:52 EST
Right, for one older releases have KHexEdit and secondly Okteta isn't fully 
ready yet, hopefully it will get the missing features (like undo/redo) in time 
for F9.

Note You need to log in before you can comment on or make changes to this bug.