Bug 42720 - ksh read command does not read from pipe
ksh read command does not read from pipe
Status: CLOSED DUPLICATE of bug 8894
Product: Red Hat Linux
Classification: Retired
Component: pdksh (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Depends On:
  Show dependency treegraph
Reported: 2001-05-29 13:26 EDT by slee
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-29 13:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description slee 2001-05-29 13:26:20 EDT
Description of Problem: The ksh read command does not read from a pipe.

How Reproducible: All the time.

Steps to Reproduce:
1. Using ksh
2. echo A B C | read AA BB CC
3. echo $AA

Actual Results: You get nothing.

Expected Results: You should get A

Additional Information:  The results are the same if you use command line 
or put results in a script.

I don't recall exact version of distribution.  I believe it is 7.0??.
uname -a gives:
Linux harley 2.2.16-22 #2 Sat Apr 21 14:10:28 CDT 2001 i586 unknown

The 'component' field would not let me specify ksh or Korn Shell (why?), 
but would not let me submit the bug without something; so I picked 
Comment 1 Trond Eivind Glomsrxd 2001-05-29 13:59:29 EDT
This isn't against 4Suite...
Comment 2 Trond Eivind Glomsrxd 2001-05-29 14:02:07 EDT

*** This bug has been marked as a duplicate of 8894 ***

Note You need to log in before you can comment on or make changes to this bug.