Bug 427219 - Sata optical drive doesn' t work with CK804 chipset Power Edge platforms
Sata optical drive doesn' t work with CK804 chipset Power Edge platforms
Status: CLOSED DUPLICATE of bug 442906
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
All Linux
high Severity high
: rc
: ---
Assigned To: David Milburn
Red Hat Kernel QE team
: OtherQA
Depends On:
Blocks: 391501 483701 485920
  Show dependency treegraph
Reported: 2008-01-02 06:13 EST by Shyam kumar Iyer
Modified: 2009-06-19 22:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-02 12:47:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Shyam kumar Iyer 2008-01-02 06:13:01 EST
Description of problem:
The sata optical drives on Dell poweredge PET105 platform is connected to
the sata controller on a CK804 nvidia chipset. 
The sata driver for this chipset i.e. sata_nv does not work properly with sata
optical drives if the system is loaded with more than 4Gb system memory.

Analysis till now:
sata_nv driver has implemented adma mode in the driver by default. Since the
ATAPI interface uses the legacy interface for I/O, the coexistance of adma 
capable disks and non-adma capable ATAPI drives is causing the driver to break 
with system memory greater than 4GB.

Workarounds/Fixes explored till now:
- passing adma=0 option as the module parameter solved the problem since the
adma mode got disabled in the driver and every device is interacted with the
legacy interface.

Please also refer the upstream comments since this bug is still upstream.


Version-Release number of selected component (if applicable):
RHEL5.1  kernel-2.6.18-53.el5

How reproducible:

Steps to Reproduce:
1.Take PET105 or any system with CK804 chipset.
2.Load system with greater than 4GB memory.
3.Attach sata optical drives to the internal sata ports.
4.Try doing CD install of RHEL5.1 or use the optical drive after OS install.
Actual results:
SATA optical drive does not work.

Expected results:
SATA optical drive should work with greater than 4Gb system memory as well.

Additional info:
Comment 1 RHEL Product and Program Management 2008-02-01 17:38:09 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Larry Troan 2008-03-10 13:08:42 EDT
Jeff have given a devel ACK. This is a problem for Dell PoiwerEdge servers and
should be fixed in 5.2. Raising exception.
Comment 3 Larry Troan 2008-03-11 10:38:32 EDT
Per Ron Pacheco, we don't have a patch for this yet. He is recommending pushing
to 5.3. I agree. Removing exception request.

We can entertain taking this into 5.2 if a patch becomes available, is mundane
and testable.
Comment 4 RHEL Product and Program Management 2008-03-11 10:39:34 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 9 Wayne Perg 2008-09-18 12:37:08 EDT
I have found that the SATA DVD chipset on the R905 can be used to install RHEL 4.6 by passing it "linux all-generic-ide" at boot up. I have not tested it with the PET105, but it may solve that issue as well
Comment 10 David Milburn 2008-09-25 11:18:00 EDT
The RHEL5.3 sata update included a change to sata_nv to disable adma by default
for this chipset, so this should work with 2.6.18-109.el5 or later kernel.
Comment 12 RHEL Product and Program Management 2009-02-16 10:05:07 EST
Updating PM score.
Comment 13 David Milburn 2009-02-17 16:47:10 EST

Have you tried this on RHEL5.3? This should no longer be a problem,
please confirm? Thank you.
Comment 14 David Milburn 2009-03-02 12:47:05 EST
I am closing this as a duplicate of BZ 442906, please re-open if necessary.

*** This bug has been marked as a duplicate of bug 442906 ***

Note You need to log in before you can comment on or make changes to this bug.