Bug 427229 - (CVE-2007-6421) CVE-2007-6421 httpd mod_proxy_balancer cross-site scripting
CVE-2007-6421 httpd mod_proxy_balancer cross-site scripting
Status: CLOSED CURRENTRELEASE
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
http://nvd.nist.gov/nvd.cfm?cvename=C...
impact=low,reported=20080102,source=i...
: Security
Depends On: 427239 427240 427241 427982 427983 427984
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-02 07:54 EST by Mark J. Cox (Product Security)
Modified: 2016-03-04 07:43 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.2.8-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 21:08:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark J. Cox (Product Security) 2008-01-02 07:54:58 EST
Common Vulnerabilities and Exposures assigned an identifier CVE-2007-6421 to the following vulnerability:

** RESERVED ** This candidate has been reserved by an organization or individual that will use it when announcing a new security problem.  When the candidate has been publicized, the details for this candidate will be provided.

References:
Comment 1 Mark J. Cox (Product Security) 2008-01-02 07:57:28 EST
according to http://marc.info/?l=apache-cvs&m=119927040920697&w=2

  *) SECURITY: CVE-2007-6421 (cve.mitre.org)
     mod_proxy_balancer: Correctly escape the worker route and the worker
     redirect string in the HTML output of the balancer manager.
     Reported by SecurityReason. [Ruediger Pluem]

This issue only affects mod_proxy_balancer and therefore only httpd-2.2
(Enterprise Linux 5, Application Stack v2 only).  This is of low security
severity as the balancer is not enabled by default, and would be protected to
only allow access by the administrator.
Comment 6 Fedora Update System 2008-02-13 09:28:41 EST
httpd-2.2.8-1.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-02-13 09:32:51 EST
httpd-2.2.8-1.fc7 has been submitted as an update for Fedora 7
Comment 8 Fedora Update System 2008-02-15 21:08:01 EST
httpd-2.2.8-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-02-15 21:10:48 EST
httpd-2.2.8-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.