Bug 427264 - Package review: tcl-html
Summary: Package review: tcl-html
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Wart
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 228782 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-02 15:49 UTC by Marcela Mašláňová
Modified: 2008-01-22 11:38 UTC (History)
3 users (show)

Fixed In Version: tcl-html-8.5.0-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 11:38:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wart: fedora-review+
kevin: fedora-cvs+


Attachments (Terms of Use)

Description Marcela Mašláňová 2008-01-02 15:49:48 UTC
Please review separated hmtl manual package for tcl.

http://mmaslano.fedorapeople.org/tcl-html/

Comment 1 Wart 2008-01-02 16:48:18 UTC
* The Provides: line is not needed, since this package doesn't actually provide
  any code.
* download urls for sourceforge are best listed as:
  URL:  http://downloads.sourceforge.net/sourceforge/tcl/tcl%{version}-html.tar.gz
  ...instead of using a hardcoded mirror.
* The RPM group would be more accurate as 'Documentation'
* A proper 'index.html' index page would be useful.  A simple one can 
  be created in either %prep or %build as a symlink to point to 'contents.htm'
  ln -s html/contents.htm html/index.html
* Minor nitpick:  I've been told by others that it's good to have
  an empty %build and %install section in the spec file instead
  of leaving them out.  Apparently there are some rpm corner cases that
  will choke if they sections are missing.  In these cases, I usually do
  this:

%build
# Nothing to build.

%install
# Nothing to install.


Comment 2 Marcela Mašláňová 2008-01-03 08:31:18 UTC
With %build part is rpm failing. The other commands were fine. Thank you for
letting me know about it.

Check the new rpm for changes.

Comment 3 Wart 2008-01-11 18:04:06 UTC
Looks good.  rpmlint is happy, the sources match upstream, and most of the other
packaging guidelines don't apply to this documentation-only package.

APPROVED

Comment 4 Wart 2008-01-12 03:55:50 UTC
*** Bug 228782 has been marked as a duplicate of this bug. ***

Comment 5 Marcela Mašláňová 2008-01-14 08:37:01 UTC
New Package CVS Request
=======================
Package Name: tcl-html
Short Description: html manual for Tcl/Tk
Owners: mmaslano
Cvsextras Commits: yes


Comment 6 Kevin Fenzi 2008-01-14 17:34:13 UTC
cvs done.


Note You need to log in before you can comment on or make changes to this bug.