Bug 427295 - missing dependency for mysql - 5.0.22-2.2.el5_1.1
Summary: missing dependency for mysql - 5.0.22-2.2.el5_1.1
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum
Version: 5.1
Hardware: x86_64
OS: Linux
Target Milestone: ---
: ---
Assignee: James Antill
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 2008-01-02 20:31 UTC by Chris Stankaitis
Modified: 2009-03-25 05:34 UTC (History)
2 users (show)

Clone Of:
Last Closed: 2009-03-25 05:34:32 UTC

Attachments (Terms of Use)

Description Chris Stankaitis 2008-01-02 20:31:44 UTC
Description of problem:

Trying to yum update... mysql for x86_64 it seems to have been built agains i?86

 Package                 Arch       Version          Repository        Size
 mysql                   x86_64     5.0.22-2.2.el5_1.1  rhel-x86_64-client-5  3.0 M
Installing for dependencies:
 device-mapper           i386       1.02.20-1.el5    rhel-x86_64-client-5  652 k
 e2fsprogs-libs          i386       1.39-10.el5      rhel-x86_64-client-5  114 k
 keyutils-libs           i386       1.2-1.el5        rhel-x86_64-client-5   18 k
 krb5-libs               i386       1.6.1-17.el5     rhel-x86_64-client-5  651 k
 libselinux              i386       1.33.4-4.el5     rhel-x86_64-client-5   94 k
 libsepol                i386       1.15.2-1.el5     rhel-x86_64-client-5  129 k
 libstdc++               i386       4.1.2-14.el5     rhel-x86_64-client-5  354 k
 mysql                   i386       5.0.22-   rhel-x86_64-client-5  3.0 M
 ncurses                 i386       5.5-24.20060715  rhel-x86_64-client-5  1.1 M
 openssl                 i686       0.9.8b-8.3.el5_0.2  rhel-x86_64-client-5  1.4 M

Transaction Summary
Install     10 Package(s)
Update       2 Package(s)
Remove       0 Package(s)

If I exclude the *i?86* RPM's as my systems are x86_64 only..

Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package subversion.x86_64 0:1.4.6-0.1.el5.rf set to be updated
---> Package mysql.x86_64 0:5.0.22-2.2.el5_1.1 set to be updated
--> Running transaction check
--> Processing Dependency: mysql = 5.0.22- for package: mysql-server
--> Finished Dependency Resolution
Error: Missing Dependency: mysql = 5.0.22- is needed by package mysql-server

please fix this up so that I can update my x86_64 only boxes.

Version-Release number of selected component (if applicable)


How reproducible:


Comment 1 Tom Lane 2008-01-02 22:23:57 UTC
The x86_64 RPMs do not have any 32-bit dependency that I can see, so the first part of your complaint is 
perhaps a yum bug?  Reassigning to yum's owner to ask for ideas.

As for the second part, you can't update mysql without updating mysql-server at the same time.  That's 

Comment 2 James Antill 2008-01-03 01:01:52 UTC
 yum sometimes doesn't do what you want with regard to mutlilib. esp. the older
versions (as in RHEL-5.1). The exclude will do what you want _assuming_ that you
don't have any .i386 versions installed already, but it looks like you have a


rpm --qf '%{name}-%|epoch?{%{epoch}:}:{0:}|%{version}-%{release}.%{arch}\n' -q
mysql mysql-server

Comment 3 Chris Stankaitis 2008-01-03 22:35:17 UTC
Actually in this case we do not...

[root@dev ~]# rpm --qf
'%{name}-%|epoch?{%{epoch}:}:{0:}|%{version}-%{release}.%{arch}\n' -q mysql


I flushed my db cache... I guess it had gotten all wonked up... I can now patch
and update fine.. sorry for the bother.. you can close this issue.

Comment 4 Tom Lane 2008-01-04 04:59:19 UTC
Hmm, do you have enough details to make this worth passing over to the rpm guys?  Because now it 
sounds like an rpm bug.

Comment 5 Chris Stankaitis 2008-01-04 15:23:55 UTC
I ran yum clean metadate && yum clean dbcache

That was all I did.. also may have fixed another issue I had.. for some reason
my yum install couldn't find mod_python... a yum install or yum search would
turn up 0 results (nothing to do) after I ran the above that did the trick there

If you can give me an idea of the data your looking for I would be happy to try
and provide it to you.

Comment 6 Chris Stankaitis 2008-01-04 19:41:16 UTC
from what I can tell, yum stopped using the channels other than base client for
some reason.  It was only updating the base client channel, not the workstation
channel etc..

Comment 7 James Antill 2009-03-25 05:34:32 UTC
This could have been a couple of weird things, esp. with those older versions of yum and yum-metadata-parser.

Note You need to log in before you can comment on or make changes to this bug.