Bug 427309 - IBM T43 won't wake up from S3 sleep with anything but power button
Summary: IBM T43 won't wake up from S3 sleep with anything but power button
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-02 22:32 UTC by Jesse Brandeburg
Modified: 2009-01-09 05:41 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-01-09 05:41:03 UTC


Attachments (Terms of Use)
output of proc/acpi/wakeup after problem (459 bytes, application/octet-stream)
2008-01-02 22:32 UTC, Jesse Brandeburg
no flags Details
dmesg through suspend/resume a few times (48.92 KB, application/octet-stream)
2008-01-02 22:33 UTC, Jesse Brandeburg
no flags Details
lsmod output (3.69 KB, application/octet-stream)
2008-01-02 22:33 UTC, Jesse Brandeburg
no flags Details

Description Jesse Brandeburg 2008-01-02 22:32:16 UTC
Description of problem:
Occasionally, usually after first boot, system wakes fine from lid event or Fn
key press.  After resume/suspend several times, the system will only wake when
the power button is pressed.

Version-Release number of selected component (if applicable):
Linux jbrandeb-linux 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686
i686 i386 GNU/Linux

How reproducible:
I can seem to reproduce at will, but I thought it was working for a bit and then
stopped working again.


Steps to Reproduce:
1. Boot F8 kernel on IBM T43 model 2668-NU3
2. Suspend using Fn-F4
3. wake using Fn key
  
Actual results:
system stays asleep until power button is pressed

Expected results:
Fn, or LID, (or i would assume magic packet) should be able to wake the laptop.

Additional info:
This problem has existed for a while but there was a bit there with some F7
kernels that it worked fine up to but after that it is failing.

I run both tpb, and thinkpad-acpi module

Comment 1 Jesse Brandeburg 2008-01-02 22:32:16 UTC
Created attachment 290681 [details]
output of proc/acpi/wakeup after problem

Comment 2 Jesse Brandeburg 2008-01-02 22:33:10 UTC
Created attachment 290682 [details]
dmesg through suspend/resume a few times

Comment 3 Jesse Brandeburg 2008-01-02 22:33:49 UTC
Created attachment 290683 [details]
lsmod output

Comment 4 Bug Zapper 2008-11-26 09:15:42 UTC
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Bug Zapper 2009-01-09 05:41:03 UTC
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.