Bug 427326 - testsuite failure
testsuite failure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-DateTime-Format-Strptime (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 419631
  Show dependency treegraph
 
Reported: 2008-01-03 00:00 EST by Ralf Corsepius
Modified: 2008-05-10 09:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0702-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-10 09:58:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-01-03 00:00:18 EST
Description of problem:
Trying to address BZ 419631 by adding BR: perl(Test::More) to this package's
spec triggers a testsuite breakdown:
...
+ make test
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0,
'blib/lib', 'blib/arch')" t/*.t
t/001_load...............ok
t/002_dates..............ok
t/003_every..............ok
t/004_locale_defaults....Can't call method "year" on an undefined value at
t/004_locale_defaults.t line 45.
# Looks like you planned 48 tests but only ran 36.
# Looks like your test died just after 36.
dubious
        Test returned status 255 (wstat 65280, 0xff00)
DIED. FAILED tests 37-48

Version-Release number of selected component (if applicable):
perl-DateTime-Format-Strptime-1_0700-4 with FC8 or FC9

[Breakdown does not occur for fc7]

Steps to Reproduce:
Build spec in Fedora's CVS with BR: perl(Test::More) added for FC8 or FC9
  
Actual results:
Cf. above. Building the package fails.

Additional info:
Upgrading the package to perl-DateTime-Format-Strptime-1.0702.tgz seems to help.
If I interpret the tarball's Changes correctly, this issue had been fixed in 1.0701.
Comment 1 Fedora Update System 2008-01-06 20:25:32 EST
perl-DateTime-Format-Strptime-1.0702-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-DateTime-Format-Strptime'
Comment 2 Jan Pazdziora 2008-03-05 08:39:49 EST
Since this bugzilla was about a build problem and since the packages were
correctly built, I propose closing with CURRENTRELEASE or something to that effect.
Comment 3 Fedora Update System 2008-05-10 09:58:31 EDT
perl-DateTime-Format-Strptime-1.0702-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.