This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 427328 - Please branch for EPEL 4, 5
Please branch for EPEL 4, 5
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: popt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 01:04 EST by Jonathan Dieter
Modified: 2008-01-03 02:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 02:19:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Dieter 2008-01-03 01:04:21 EST
Description of problem:

Please branch for EPEL 4 and 5 so deltarpm is usable.

https://bugzilla.redhat.com/show_bug.cgi?id=426959
Comment 1 Robert Scheck 2008-01-03 02:19:36 EST
Jonathan, it is not possible to branch popt from Fedora 8/Rawhide to EPEL, 
because popt is already in RHEL and EPEL is not allowed to replace any base 
package. Please use the popt which is already there (and bundled with RPM).

The version is older and you've to "BuildRequire: %{_includedir}/popt.h", if 
you don't want to "BuildRequire: popt" on RHEL 4, RHEL 5, Fedora 7 and then 
"BuildRequire: popt-devel" on Fedora 8 and Rawhide - at least, that's how I'm 
working smart around this.

As branching Fedora 8/Rawhide popt is never possible for EPEL, I'll close
this bug report with CAN'T FIX now.
Comment 2 Jonathan Dieter 2008-01-03 02:34:47 EST
Sorry, that's my bad.  I completely forgot that F8 had changed the BuildRequire
to popt-devel, so I just assumed popt as a whole wasn't in RHEL (and knew it
wasn't in EPEL).

My apologies for the noise. 

Note You need to log in before you can comment on or make changes to this bug.