This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 42733 - rpm-4.0.3-26 segfaults on solaris 2.6
Summary: rpm-4.0.3-26 segfaults on solaris 2.6
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-29 19:56 UTC by Nathan Owen
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 19:56:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan Owen 2001-05-29 19:56:49 UTC
Description of Problem:
rpm segfaults upon being run on solaris. This is because the uname()
syscall on solaris returns non-negative on success, whereas on linux it
returns 0 on success.

changing line 982 in lib/rpmrc.c
from 
	if (rc) return;
to
	if (rc < 0) return;

appears to fix this

How Reproducible:


Steps to Reproduce:
1. rpm
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Jeff Johnson 2001-05-29 20:05:49 UTC
Fixed in next checkin, should be in rpm-4.0.3-0.29.


Note You need to log in before you can comment on or make changes to this bug.