Bug 427338 - can paste user's X clipboard contents when leaving a note
can paste user's X clipboard contents when leaving a note
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 03:48 EST by Jens Petersen
Modified: 2015-01-14 18:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 17:57:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-01-03 03:48:06 EST
Description of problem:
I just noticed that one can paste the user's clipboard
into the note taking box or password entry box when leaving
a note.


How reproducible:
every time

Steps to Reproduce:
1. lock screen
2. paste into password box with Ctrl-v or button2
2. click on leave a note
3. paste into note box
  
Actual results:
2. clipboard is pasted to password entry
4. clipboard contents appear

Expected results:
might be good to disable pasting in the screensaver
Comment 1 Ray Strode [halfline] 2008-01-03 10:42:45 EST
there's a dupe of this somewhere, and it's fixed in upstream svn, so it should
get fixed in the next stable release.

Note You need to log in before you can comment on or make changes to this bug.