Bug 42735 - Anaconda doesn't stop with type 0 partitions present
Anaconda doesn't stop with type 0 partitions present
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-05-29 16:05 EDT by Jeremy Fitzhardinge
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-29 16:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeremy Fitzhardinge 2001-05-29 16:05:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4 i686; en-US; 0.8.1) Gecko/20010421

Description of problem:
Early on in the install process, anaconda warns about type 0 partitions on
hda (holes left there by Partition Magic).  It says it cannot proceed, but
does so anyway.  Later, when configuring LILO, it crashes because there are
no partitions in its list of bootable partitions, and it dies with an array
out of bounds exception.

How reproducible:

Steps to Reproduce:
1.create a type 0 partition
2.try to install.  Carry on after warning about type 0 partitions
3.try to configure LILO

Actual Results:  LILO configuration crashes with an array bounds exception
and the system reboots

Expected Results:  Either:
- installation should cope with type 0 partitions (what's the problem?)
- installation should cleanly stop when it detects them

Additional info:

I worked around it by using Partition magic to create a couple of ext2
filesystems in the gaps.  The installer was happy with this.
Comment 1 Brent Fox 2001-05-29 17:51:55 EDT
I don't know exactly what the problem is.  I don't have Partition Magic, but I
tried making type 0 partitions with fdisk.  I get a message saying:

"Type 0 means free space to many systems (but not to Linux).  Having partitions
of type 0 is probably unwise.  You can delete a partition using the 'd' command.
Changed system type of partition 1 to 0 (Empty)"

The entire partitioning subsystem is being re-engineered, so this problem will
be addressed in a future release.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.