Bug 42737 - "Next" button doesn't work after fdisk during GUI install
"Next" button doesn't work after fdisk during GUI install
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-29 16:46 EDT by Jim Prior
Modified: 2007-04-18 12:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-26 17:11:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Prior 2001-05-29 16:46:04 EDT
Description of Problem:

"Next" button doesn't work after fdisk, 
until one moves the cursor off of the "Next" button, then back on.  

How Reproducible: Consistent


Steps to Reproduce:
1. GUI install, use fdisk to partition
2. While actually in fdisk, 
   leave mouse over greyed out "Next" button.  
3. Write the partition table, leaving mouse over "Next" button.  
4. When screen shows "Select drive to run fdisk on" again, 
   clicking the mouse button on the "Next" button that it is still over, 
   just boldens the button's border, without advancing to the next screen. 
5. Move the mouse off of the button, then back on for button to work.  

Actual Results: Clicking "Next" button doesn't advance to next screen 
                if mouse has been left over "Next" button.  


Expected Results: Clicking "Next" button advances to next screen 
                  without having to move mouse off of button, 
                  then back on.


Additional Information:
Comment 1 Brent Fox 2001-05-29 17:17:00 EDT
I have reproduced this problem.
Comment 2 Brent Fox 2001-05-29 17:23:16 EDT
It's weird, though, because we are re-enabling the "Next" button, but it's not
grabbing the focus.
Comment 3 Brent Fox 2001-06-26 17:11:36 EDT
I think this is more of a GTK problem with grabbing the focus when the child
window is destroyed.  This problem only happens if the mouse is over the button
when you exit fdisk.  As such, I think this is pretty uncommon and isn't worth
fixing, given the number of other issues that we're looking at.

Note You need to log in before you can comment on or make changes to this bug.