Bug 427375 - Creating a CD set in revisor only gives me the SHA1SUM, no ISOs
Creating a CD set in revisor only gives me the SHA1SUM, no ISOs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-03 11:12 EST by Jon Ciesla
Modified: 2008-05-12 14:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 14:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Revisor log, debug mode (102.90 KB, text/plain)
2008-01-03 13:30 EST, Jon Ciesla
no flags Details

  None (edit)
Description Jon Ciesla 2008-01-03 11:12:31 EST
I ran revisor on f-8, tried to create a set, and it looked like everything was
fine, but all I got in /srv/revisor/f8-i386/iso was the SHA1SUM.

Version 2.0.5-14, f8.
Comment 1 Jeroen van Meeuwen 2008-01-03 11:22:52 EST
Thanks for creating a separate bug, Jon

Tell me if the SHA1SUM file has any entries at all, please

If you build with --install-tree, is the tree created properly? Is disk space an
issue (at all)? If all else fails, please attach the output of a --debug run.
Comment 2 Jon Ciesla 2008-01-03 11:35:19 EST
cat SHA1SUM
/usr/bin/sha1sum: F-8-i386-CD.iso: No such file or directory


Not sure about --install-tree, ran from the desktop, so no flags passed.

Disk space isn't an issue, I don't think.  I have /srv/revisor symlinked to a
large partition (9.6GB free).  Would I need equivalent space available on
/var/tmp?  Not familiar with how it moves the bits around.  If needed, I can
shift /var/tmp to the larger dik and try again.
Comment 3 Jon Ciesla 2008-01-03 11:36:51 EST
s/dik/disk/g.  Yikes.
Comment 4 Jon Ciesla 2008-01-03 11:39:50 EST
Correction, /var/tmp IS on the larger disk.
Comment 5 Jeroen van Meeuwen 2008-01-03 11:47:41 EST
Judging from the name (F-8-i386-CD.iso not having a disc number), that should be
large enough alright.

I have not seen this behaviour yet. Is genisoimage installed? I just found out
it isn't a requirement of the revisor package.
Comment 6 Jon Ciesla 2008-01-03 12:02:51 EST
genisoimage-1.1.6-6.fc8


FWIW, revisor worked before I upgraded from F7 to F8.
Comment 7 Jeroen van Meeuwen 2008-01-03 12:11:03 EST
I'd like to see the output of revisor once you started it with the --debug flag.
From a terminal, run:

sudo revisor --debug 2>&1 |tee revisor.log
Comment 8 Jon Ciesla 2008-01-03 13:30:40 EST
Created attachment 290756 [details]
Revisor log, debug mode

Same result.  Diskspace is still fine afterward, FWIW.
Comment 9 Jeroen van Meeuwen 2008-02-15 21:09:40 EST
Trying to reproduce the issue locally with the master GIT branch.
Comment 10 Jeroen van Meeuwen 2008-02-16 11:51:33 EST
Cannot reproduce using the master branch, trying the 2.0.5 F-8 branch now
Comment 11 Jeroen van Meeuwen 2008-05-10 12:53:48 EDT
I'm sorry I've taken so long, but this still is not reproducible for me, unless
I fake not enough diskspace. You could try with the latest Revisor, and possibly
suspend (ctrl-z) it during the mkisofs stage, and then run the command manually
see if it has any errors in the output?
Comment 12 Jon Ciesla 2008-05-12 14:44:47 EDT
Hmm, now I can't reproduce it.  I think I misunderstood all the places I needed
certain amounts of free disk.  I've since moved /tmp to another partition and it
works swimingly. 

Sorry for the confusion.

Note You need to log in before you can comment on or make changes to this bug.