Bug 427404 - Please update to 5.48 (patch included)
Please update to 5.48 (patch included)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-DateManip (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 427542
  Show dependency treegraph
 
Reported: 2008-01-03 12:43 EST by Ed Avis
Modified: 2008-03-13 03:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: perl-Date-Manip.noarch 0:5.48-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 04:05:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)
Patch to spec file (1.75 KB, patch)
2008-01-03 12:43 EST, Ed Avis
no flags Details | Diff
Redone version of patch to run 'date +%z' (1.11 KB, patch)
2008-01-03 12:46 EST, Ed Avis
no flags Details | Diff

  None (edit)
Description Ed Avis 2008-01-03 12:43:54 EST
Please update Date::Manip to version 5.48 from CPAN.
Comment 1 Ed Avis 2008-01-03 12:43:54 EST
Created attachment 290747 [details]
Patch to spec file
Comment 2 Ed Avis 2008-01-03 12:46:38 EST
Created attachment 290749 [details]
Redone version of patch to run 'date +%z'

I have re-applied the patch for #248500 by hand.  It does need re-testing in
the same environment that required the original patch.
Comment 3 Robin Norwood 2008-01-03 13:41:58 EST
Ok.  Since the upstream tarball changed names, it looks like the right thing to
do is to kill the old fedora package named perl-DateManip and create a new one
called perl-Date-Manip.  I'll get started on that with a CVS request:

New Package CVS Request
=======================
Package Name: perl-Date-Manip
Short Description: A Perl module containing a wide variety of date manipulation
routines
Owners: rnorwood@redhat.com
Branches: F-8
InitialCC: fedora-perl-devel-list@redhat.com
Cvsextras Commits: yes

Comment 4 Kevin Fenzi 2008-01-03 23:31:22 EST
cvs done.

looks like the 'cvsplot' package requires the old name. You might ping the
maintainer to fix it to the new package. 
Comment 5 Ed Avis 2008-01-04 10:56:27 EST
I have filed #427542 for cvsplot to rename its dependency, but I know there are
third party packages depending on Date::Manip, so you need

Provides: perl-DateManip 5.48
Obsoletes: perl-DateManip 5.48

or whatever the exact rpm voodoo is so that existing packages keep working.

I guess once the change works its way through the system a new package will
appear in
<http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/>?
Comment 6 Robin Norwood 2008-01-04 12:03:21 EST
Yeah, I think we'll need:

Provides: perl-DateManip = %{version}-%{release}
Obsoletes: perl-DateManip < 5.48-1

I'll add that to the spec as well as your patch, and some other housekeeping
business.
Comment 7 Robin Norwood 2008-01-04 16:02:35 EST
Ok, built for rawhide and F-8.  I'll push the update to F-8 to final when
someone tells me it works.
Comment 8 Robin Norwood 2008-01-04 17:07:16 EST
By the way, Ed, if you use this package and want to maintain (or co-maintain)
it, you're welcome to do so, just let me know.
Comment 9 Fedora Update System 2008-01-06 20:27:29 EST
perl-Date-Manip-5.48-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Date-Manip'
Comment 10 Ed Avis 2008-01-08 11:07:32 EST
I am running the new package (rebuilt from the SRPM) and it works.  However I am
not the best person to test the upgrade path since I was already running my own
version of the package.  Let me check it on my F8 machine at home.
Comment 11 Marcela Mašláňová 2008-02-22 08:49:04 EST
Please could you verify the result of update?
Comment 12 Ed Avis 2008-02-28 18:21:35 EST
Running 'yum --enablerepo=updates-testing update perl-Date-Manip' as root gives
the error

Could not find update match for perl-Date-Manip

This on a machine running Fedora 8 for x86_64.
Comment 13 Marcela Mašláňová 2008-02-29 05:37:15 EST
For me helped yum --enablerepo=updates-testing install perl-Date-Manip because
with previous command wasn't package found.

But there is still ugly message when you already have perl-Date-Manip and want
install perl-DateManip.

Transaction Check Error:
  file /usr/lib/perl5/vendor_perl/5.8.8/Date/Manip.pm from install of
perl-DateManip-5.44-4.fc8.noarch conflicts with file from package
perl-Date-Manip-5.48-1.fc8.noarch
  file /usr/lib/perl5/vendor_perl/5.8.8/Date/Manip.pod from install of
perl-DateManip-5.44-4.fc8.noarch conflicts with file from package
perl-Date-Manip-5.48-1.fc8.noarch
  file /usr/share/man/man3/Date::Manip.3pm.gz from install of
perl-DateManip-5.44-4.fc8.noarch conflicts with file from package
perl-Date-Manip-5.48-1.fc8.noarch

There will be needed some triggers in spec file. Thoughts?
Comment 14 Jan Pazdziora 2008-03-05 09:11:46 EST
The path from DateManip to Date-Manip seems to work:

# rpm -qa | grep Manip
perl-DateManip-5.44-4.fc8.noarch
# yum --enablerepo=updates-testing install perl-Date-Manip
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package perl-Date-Manip.noarch 0:5.48-1.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 perl-Date-Manip         noarch     5.48-1.fc8       updates-testing   164 k

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 164 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): perl-Date-Manip-5. 100% |=========================| 164 kB    00:00     
warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
Importing GPG key 0x30C9ECF8 "Fedora Project (Test Software)
<rawhide@redhat.com>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: perl-Date-Manip              ######################### [1/2] 
  Erasing   : perl-DateManip               ######################### [2/2] 

Installed: perl-Date-Manip.noarch 0:5.48-1.fc8
Complete!
#

Therefore, proposing CURRENTRELEASE.
Comment 15 Fedora Update System 2008-03-13 03:37:34 EDT
perl-Date-Manip-5.48-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.